Bug 5940 - gvim 5.4 crashes
Summary: gvim 5.4 crashes
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-14 08:36 UTC by mirjamv
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-24 16:53:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mirjamv 1999-10-14 08:36:45 UTC
On my redhat 6.1 system gvim 5.4 crashes with the following
error:

prompt % gvim print_int_mat.m
Gdk-ERROR **: X connection to :0.0 broken (explicit kill
or server shutdown). child process failed to start gui

After this error normal vim is started and I can edit the
file. Normal vim also prints a "c" to standard-output before
exiting, so the prompt that appears after using vim looks
like

cprompt %

Finally the file "scripts.vim" is located in
  /usr/share/vim/vim54/
while vim searches for it in
  /usr/share/vim/vim54/syntax

Comment 1 Michael K. Johnson 1999-11-19 15:23:59 UTC
gvim WorksForMe[TM].

The "c" is a bug in gnome-terminal, not vim, I think.  It has been
separately filed as a bug against gnome-core, which contains gnome-terminal.

Would you care to try vim 5.5 from RawHide and see if it fixes the
scripts problem?  For that matter, could you check if it fixes the
gvim problem that you are experiencing and that I cannot reproduce?

Thanks!

Comment 2 Michael K. Johnson 1999-11-24 16:53:59 UTC
Mirjam reports in private email that 5.5 fixes all the reported problems.

Since the only serious problem here is the crash that I haven't heard
other reports of and which I can't reproduce, I'll consider this fixed
by RawHide.  If we get more reports of the crashing, we can consider an
official update.


Note You need to log in before you can comment on or make changes to this bug.