Bug 594084 - wrong users and groups creation in spec file
Summary: wrong users and groups creation in spec file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openssh (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
high
Target Milestone: rc
: ---
Assignee: Jan F. Chadima
QA Contact: Karel Srot
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 593683
TreeView+ depends on / blocked
 
Reported: 2010-05-20 14:27 UTC by Peter Vrabec
Modified: 2010-11-10 21:16 UTC (History)
3 users (show)

Fixed In Version: openssh-5.3p1-15.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:16:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Vrabec 2010-05-20 14:27:22 UTC
Description of problem:
Please fix user/group creation in your spec file[1]. There were problems when (UID != GID) && (UID<200) [2]. For example: tryitd:x:194:482:TryIt:/:/sbin/nologin

Problem was caused by change/fix of shadow-utis behaviour. useradd does not create group with same GID as user's UID for IDs < 200 (static/reserved) unless it's done this way:

getent group qemu >/dev/null || groupadd -g 107 -r qemu
getent passwd qemu >/dev/null || \
  useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
    -c "qemu user" qemu


This issue should be fixed as soon as possible. Note, it can't be resolved by any update once we have RHEL6 GA, thnx..

--------
[1] https://fedoraproject.org/wiki/Packaging:UsersAndGroups 
[2] https://bugzilla.redhat.com/show_bug.cgi?id=593683

Comment 1 Fedora Update System 2010-05-21 14:02:09 UTC
openssh-5.4p1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openssh-5.4p1-2.fc13

Comment 4 RHEL Product and Program Management 2010-05-24 08:26:01 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Jan F. Chadima 2010-05-24 09:08:06 UTC
Updated according to recommendation.

Comment 7 Fedora Update System 2010-06-01 18:14:10 UTC
openssh-5.4p1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 releng-rhel@redhat.com 2010-11-10 21:16:59 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.