Bug 59413 - Places library under /usr/share
Places library under /usr/share
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: g-wrap (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 66070 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-07 09:26 EST by Enrico Scholz
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 18:12:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-02-07 09:26:17 EST
Description of Problem:

g-wrap contains architecture-dependent libraries under /usr/share:

| $ file /usr/share/guile/g-wrapped/libgw-runtime.so.0.0.0 
| /usr/share/guile/g-wrapped/libgw-runtime.so.0.0.0: ELF 32-bit LSB shared
object, Intel 80386, version 1 (SYSV), not stripped
|
| $ rpm -qf 
| g-wrap-1.2.1-2


This violates the FHS which requires that /usr/share/... can be shared between
different architectures.


Version-Release number of selected component (if applicable):

g-wrap-1.2.1-2
Comment 1 Bill Nottingham 2002-11-06 23:02:09 EST
*** Bug 66070 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2005-01-21 18:12:00 EST
This is fixed in g-wrap-1.3.x.

Note You need to log in before you can comment on or make changes to this bug.