Bug 59418 - Kickstart gives "No drives found"
Kickstart gives "No drives found"
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-07 10:41 EST by Flash Wilson
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-14 09:55:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart config file (2.73 KB, text/plain)
2002-02-07 10:45 EST, Flash Wilson
no flags Details
Latest kickstart config file (3.19 KB, text/plain)
2002-02-14 06:57 EST, Flash Wilson
no flags Details
Anaconda crash dump from kickstarting (66.39 KB, text/plain)
2002-02-14 09:31 EST, Flash Wilson
no flags Details

  None (edit)
Description Flash Wilson 2002-02-07 10:41:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Kickstarting RH7.2 on a Compaq DL360, which has been smartstarted. Server gets 
a lease from kickstart server, finds its config file, begins to install. Just 
after the message that Anaconda is starting, the following error shows: 

NO DRIVES FOUND
An error has occurred - no valid devices were found on which to create new 
filesystems. Please check your hardware for the cause of this problem.

ALT-F1 gives that install screen
ALT-F2 gives shell prompt
ALT-F3 gives "no IDE floppy devices found" as the last message
ALT-F4 gives "<4> unable to identify CD-ROM format" and then "<6> cdrom: open 
failed"(twice) as the last messages

I have previously used this kickstart server to install 7.1. 
I have tested with a second boot floppy but the problem still occurs. On the 
boot floppy I am using the bootnet.img from the Jan 17/22 2002 errata & 
updates, with my syslinux.cfg file that has previously worked with 7.1 
kickstarts. 

I have run my kickstart config file past people on the GLLUG mailing list, but 
attach it just in case.

I do not think it is an issue with Compaq array / Compaq smartstart, because I 
have smartstarted the server in exactly the same way, and it works fine when I 
install 7.2 manually, from CD. Plus the error occurs once Anaconda has started 
running. 

I have tried this several times and the exact same error happens every time. 
Please help! I cannot see a similar bug already listed at a glance at all 
anaconda bugs, plus I am using the latest versions.

I do not have any other hardware on which to test this, only DL360, with RAID 
array.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take a compaq DL360 server which has been smartstarted.
2. Insert bootnet floppy
3. Reboot. 	

Actual Results:  Server DHCPs, gets lease, finds kickstart config file, starts 
anaconda, then bombs out with errors as above.


Expected Results:  Server should have installed from kickstart.

Additional info:

This is high priority: A manual install and postinstall configuration takes 
several hours. A kickstarted install takes under an hour, plus it can be 
repeated identically, so this is a very high priority for me.

Please get in touch if there is anything I can do to help this get fixed. 
Thanks!
Comment 1 Flash Wilson 2002-02-07 10:45:38 EST
Created attachment 44877 [details]
Kickstart config file
Comment 2 Michael Fulbright 2002-02-07 13:04:21 EST
If you goto VC2 and type 'lsmod' are the modules loaded for the array?

What kind of card is the array attached to?
Comment 3 Flash Wilson 2002-02-08 05:11:16 EST
It's an integrated Compaq smart array controller - the standard on a DL360.

When I do lsmod I only get the following modules: nfs, lockd, sunrpc and 
eepro100.

Hope that helps. I'll leave the status unchanged but please let me know if you 
need more info... thanks!
Comment 4 Flash Wilson 2002-02-12 10:03:18 EST
Hi,

Is there anything I can do to help with a resolution on this, because I 
urgently need to get this working... 

Thanks.
Comment 5 Matt Wilson 2002-02-12 15:33:25 EST
does your boot floppy match that of the NFS server you're trying to install from?
You filed this bug against 7.2 but your nfs line in ks.cfg points to 7.1
Comment 6 Flash Wilson 2002-02-14 06:52:03 EST
Oh dear - the RH7.1 is a red herring. 

To explain, I was using a specific file to test, which I will attach... 
although when I logged the bug I created a new test file which was not specific 
to our customer. I forgot that, as we cant make 7.2 install from kickstart, my 
script is only creating config files for 7.1 at the minute! My apologies. 

I assure you that in the version I am using it says 7.2, and still doesnt work.
Comment 7 Flash Wilson 2002-02-14 06:57:46 EST
Created attachment 45679 [details]
Latest kickstart config file
Comment 8 Flash Wilson 2002-02-14 09:28:27 EST
Ok. I went back to my config file flash01p1.cfg and corrected it to say 7.2.

(The bvoas03p2.cfg file is from a customer installation which I had the same 
error with. Coming back to testing I decided to use flash01p1.cfg and correct 
it to say 7.2 to be the same as the bvoas03p2.cfg file, but in my name.)

I kickstarted and got an unhandled exception error, just after it said "Loading 
anaconda" and while the white RedHat logo screen is showing. I will attach it 
and hope it helps!

Please let me know what else I can do to help. Thanks.
Comment 9 Flash Wilson 2002-02-14 09:31:50 EST
Created attachment 45699 [details]
Anaconda crash dump from kickstarting
Comment 10 Flash Wilson 2002-02-14 09:55:29 EST
Ive found the cause of the exception - it didnt recognise some of my software 
names which were good in 7.1 but not 7.2. Im commenting them out as I find them 
and starting over. 

Ill update the ticket with progress when I either hit a brick wall or get it to 
work - more soon.
Comment 11 Matt Wilson 2002-02-14 10:04:23 EST
Right, everything should be fine once you fix your ks.cfg file.
Comment 12 Flash Wilson 2002-02-14 11:32:23 EST
Ok... finally found that some of the package names were wrong for 7.2, so I 
have changed them, testing again.

Looks to work! I will check before closing the ticket - thanks so much for your 
help.

If you have any specific info on Compaq hardware with RedHat 7.2, Id be 
interested.

Note You need to log in before you can comment on or make changes to this bug.