Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 59426 - Upgrade to latest pkg-config
Upgrade to latest pkg-config
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pkgconfig (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-07 13:40 EST by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 10:08:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-02-07 13:40:11 EST
Description of Problem:

When having a PKG_CONFIG_PATH ending with a '/', the character before will be
stripped also:

| $ PKG_CONFIG_PATH='bar/' strace -eopen pkg-config foo
| ...
| open("ba", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOENT (No such
file or directory)


scan_dir() in pkg.c seems to be responsible:

| if (dirnamelen > 1 && dirname[dirnamelen-1] == G_DIR_SEPARATOR)
|   {
|      dirnamelen--;
|      dirname_copy[dirnamelen-1] = '\0';
|   }

Since decrementing happened already, the '[dirnamelen-1]' should be replaced by
a simple '[dirnamelen]'.

I could not find another bugreport-address, so please forward this report to
upstream!


Version-Release number of selected component (if applicable):

pkgconfig-0.9.0-2
Comment 1 Havoc Pennington 2002-02-12 16:31:35 EST
Fixed in CVS pkg-config, will be in Red Hat when we upgrade to pkg-config 0.12:

2002-02-12  Havoc Pennington  <hp@redhat.com>

	* pkg.c (scan_dir): use g_strdup, and fix the location where 
	we assign the nul byte, so we don't mangle things for directories
	that end in '/' - reported by Enrico Scholz
Comment 2 Havoc Pennington 2002-03-08 11:28:28 EST
Upgraded.

Note You need to log in before you can comment on or make changes to this bug.