Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594410 - [vdsm] [libvirt intg] unable to start domain with attached 'CD' which located on root_squash nfs
[vdsm] [libvirt intg] unable to start domain with attached 'CD' which located...
Status: CLOSED DUPLICATE of bug 601249
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.1
All Linux
low Severity high
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks: 581275
  Show dependency treegraph
 
Reported: 2010-05-20 11:27 EDT by Haim
Modified: 2014-01-12 19:46 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 09:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2010-05-20 11:27:20 EDT
Description of problem:

unable to start domain via virsh when 'CD' with root_squash nfs path is attached to it. 
following error appears: 

virsh # create /tmp/1.xml 

[root@pink-nehalem2 tmp]# virsh create /tmp/nocd1.xml 
error: Failed to create domain from /tmp/nocd1.xml
error: internal error process exited while connecting to monitor: qemu: could not open disk image /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/images/44495f41-cd34-43a6-95be-a8817ec1c803/7d838431-aef3-4d62-a89a-8b629a2ffa67: No such file or directory
permission on path: 

path above has no permission for root user, however, it has permissions for vdsm\kvm user. 

This is a regression on libvirt-0.8.1-6.el6.x86_64. 

used the following xml: 
<domain type="kvm">
	<name>libvirt-pool-08</name>
	<uuid>0f8e9155-8782-4d71-aa55-83257f900841</uuid>
	<memory>524288</memory>
	<currentMemory>524288</currentMemory>
	<vcpu>1</vcpu>
	<devices>
		<disk device="disk" type="block">
			<source dev="/rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/images/44495f41-cd34-43a6-95be-a8817ec1c803/7d838431-aef3-4d62-a89a-8b629a2ffa67"/>
			<target bus="ide" dev="hda"/>
			<serial>a6-95be-a8817ec1c803</serial>
			<driver cache="none" name="qemu" type="qcow2"/>
		</disk>
		<disk device="cdrom" type="file">
			<source file="/rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/80c436b7-1857-4988-a39e-d72fed4de5e7/images/11111111-1111-1111-1111-111111111111/Fedora-10-x86_64-DVD.iso"/>
			<target bus="ide" dev="hdc"/>
		</disk>
		<interface type="bridge">
			<mac address="00:1a:4a:23:71:18"/>
			<model type="virtio"/>
			<source bridge="rhevm"/>
		</interface>
		<input bus="usb" type="tablet"/>
		<graphics autoport="yes" keymap="en-us" listen="0" passwd="12345" passwdValidTo="1970-01-01T00:00:01" port="-1" type="vnc"/>
	</devices>
	<os>
	<type arch="x86_64" machine="pc">hvm</type>
		<boot dev="cdrom"/>
		<boot dev="hd"/>
		<boot dev="network"/>
	</os>
	<clock adjustment="10800" offset="variable"/>
	<features>
		<acpi/>
	</features>
	<cpu match="exact">
		<model>qemu64</model>
		<topology cores="1" sockets="1" threads="1"/>
		<feature name="sse2" policy="require"/>
		<feature name="cx16" policy="require"/>
		<feature name="ssse3" policy="require"/>
		<feature name="svm" policy="disable"/>
	</cpu>
</domain>

How reproducible: always
Comment 1 Daniel Berrange 2010-05-20 11:36:45 EDT
Please provide the /var/log/libvirt/qemu/libvirt-pool-08.log  file.

Also was does these commands show

 # ls -ld /rhev/data-center/
 # ls -ld /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/
 # ls -ld /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/images/
 # ls -l /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/images/44495f41-cd34-43a6-95be-a8817ec1c803/7d838431-aef3-4d62-a89a-8b629a2ffa67
Comment 2 Haim 2010-05-20 11:48:51 EDT
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/libexec/qemu-kvm -S -M rhel6.0.0 -cpu qemu64,+cx16,+ssse3,-svm -enable-kvm -m 512 -smp 1,sockets=1,cores=1,threads=1 -name libvirt-pool-08 -uuid 0f8e9155-8782-4d71-aa55-83257f900841 -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/libvirt-pool-08.monitor,server,nowait -mon chardev=monitor,mode=control -rtc base=2010-4-20T18:48:48 -boot dcn -drive file=/rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/images/44495f41-cd34-43a6-95be-a8817ec1c803/7d838431-aef3-4d62-a89a-8b629a2ffa67,if=none,id=drive-ide0-0-0,boot=on,format=qcow2,serial=a6-95be-a8817ec1c803,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/80c436b7-1857-4988-a39e-d72fed4de5e7/images/11111111-1111-1111-1111-111111111111/Fedora-10-x86_64-DVD.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=23,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:23:71:18,bus=pci.0,addr=0x4 -usb -device usb-tablet,id=input0 -vnc 0:1,password -k en-us -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 
qemu: could not open disk image /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/images/44495f41-cd34-43a6-95be-a8817ec1c803/7d838431-aef3-4d62-a89a-8b629a2ffa67: No such file or directory
Comment 5 Haim 2010-05-21 11:07:17 EDT
drwxr-xr-x. 5 vdsm kvm 4096 May 20 16:06 /rhev/data-center/

drwxrwx---. 4 vdsm kvm 4096 May 20 16:06 /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/

drwxrwx---. 8 vdsm kvm 4096 May 20 17:14 /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/images/

lrwxrwxrwx. 1 vdsm kvm 78 May 20 17:14 /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-8657-523bc5b6733b/images/44495f41-cd34-43a6-95be-a8817ec1c803/7d838431-aef3-4d62-a89a-8b629a2ffa67 -> /dev/d9124e52-d42a-4b0c-8657-523bc5b6733b/7d838431-aef3-4d62-a89a-8b629a2ffa67
Comment 6 Daniel Berrange 2010-05-24 05:02:08 EDT
> lrwxrwxrwx. 1 vdsm kvm 78 May 20 17:14
> /rhev/data-center/606d043c-ef9c-4c6f-848b-5bd89325c78d/d9124e52-d42a-4b0c-
> 8657-523bc5b6733b/images/44495f41-cd34-43a6-95be-a8817ec1c803/7d838431-
> aef3-4d62-a89a-8b629a2ffa67 ->
> /dev/d9124e52-d42a-4b0c-8657-523bc5b6733b/7d838431-aef3-4d62-
> a89a-8b629a2ffa67    


Ok, this is *NOT* an NFS file as per the initial report. It is a block device of some kind. Can you show me what  this outputs:

# ls -l /dev/d9124e52-d42a-4b0c-8657-523bc5b6733b/7d838431-aef3-4d62-a89a-8b629a2ffa67
Comment 7 Haim 2010-05-24 11:41:10 EDT
[root@pink-nehalem2 ~]# ls -l /dev/d9124e52-d42a-4b0c-8657-523bc5b6733b/7d838431-aef3-4d62-a89a-8b629a2ffa67 
lrwxrwxrwx. 1 root root 8 May 24 14:30 /dev/d9124e52-d42a-4b0c-8657-523bc5b6733b/7d838431-aef3-4d62-a89a-8b629a2ffa67 -> ../dm-25
Comment 8 Daniel Berrange 2010-05-27 06:38:10 EDT
There was a serious flaw in a recent KVM build that caused pretty much all guests to fail to launch. I believe this is the cause of this bug.

Can you upgrade to 

   qemu-kvm-0.12.1.2-2.68.el6
   libvirt-0.8.1-7.el6

and try to reproduce again.
Comment 9 Daniel Berrange 2010-06-08 09:50:44 EDT
Since guest is using the same symlinks in /dev that caused a problem with bug 601249 due to a selinux policy issue. Thus I believe they are both the same bug.

*** This bug has been marked as a duplicate of bug 601249 ***

Note You need to log in before you can comment on or make changes to this bug.