Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594523 - Wrong axis mode for absolute axes
Wrong axis mode for absolute axes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 18:41 EDT by Peter Hutterer
Modified: 2010-11-15 09:52 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-server-1.7.7-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:52:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hutterer 2010-05-20 18:41:13 EDT
Description of problem:
Absolute axes are assigned wrong by the wacom driver. The reason is an extra flag supplied by the driver (OutOfProximity) that's added to the Relative/Absolute setting in the mode field.

Relative and Absolute aren't meant as flags, hence many clients and the server often only have a binary test in the form of 
  if (mode == Relative) else
or 
  if (mode == Absolute) else

With the OutOfProximity flag (0x2) binary OR'd those checks fail, leading to client-implementation dependent interpretation of axis modes.

Version-Release number of selected component (if applicable):
xorg-x11-drv-wacom-0.10.5-2.el6

How reproducible:
xinput --list --long | less, then look at the axis mode of stylus, eraser (should be absolute by default)


Additional info:
Patch from upstream, simply remove the invalid OutOfProximity flag.
Patch on list archives: http://sourceforge.net/mailarchive/forum.php?thread_name=AANLkTimqYpXuEChPzwJ5lDsPZyB4orm24Vmd0ypSQzpz%40mail.gmail.com&forum_name=linuxwacom-devel
Comment 1 RHEL Product and Program Management 2010-05-20 18:56:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Peter Hutterer 2010-05-25 21:09:13 EDT
MODIFIED

xorg-x11-drv-wacom-0.10.5-3.el6 is available in brew.
Comment 5 Peter Hutterer 2010-06-09 20:43:09 EDT
Changing component to xorg-x11-server. The underlying cause turned out to be a problem in the protocol parsing code in the server.

xorg-x11-server-1.7.7-7.el6 is available in brew.
Comment 6 releng-rhel@redhat.com 2010-11-15 09:52:40 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.