Bug 594552 - crash with --no-daemon --log-level=DEBUG
crash with --no-daemon --log-level=DEBUG
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 21:53 EDT by Bill Nottingham
Modified: 2014-03-16 23:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-11 10:17:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-05-20 21:53:00 EDT
Description of problem:

NetworkManager[25660]: <warn> /sys/devices/virtual/net/virbr0: couldn't determine device driver; ignoring...
-- Error received: File exists
-- Original message: type=0x14 length=56 flags=<REQUEST,ACK,ATOMIC> sequence-nr=1274406455 pid=4219964
NetworkManager[25660]: <debug> [1274406431.173507] [nm-netlink-monitor.c:117] link_msg_handler(): netlink link message: iface idx 2 flags 0x1002
NetworkManager[25660]: <debug> [1274406431.175518] [nm-netlink-monitor.c:117] link_msg_handler(): netlink link message: iface idx 1 flags 0x10049
NetworkManager[25660]: <debug> [1274406431.175631] [nm-netlink-monitor.c:117] link_msg_handler(): netlink link message: iface idx 2 flags 0x1002
NetworkManager[25660]: <debug> [1274406431.175727] [nm-netlink-monitor.c:117] link_msg_handler(): netlink link message: iface idx 3 flags 0x1003
NetworkManager[25660]: <debug> [1274406431.175826] [nm-netlink-monitor.c:117] link_msg_handler(): netlink link message: iface idx 5 flags 0x11043
NetworkManager[25660]: <debug> [1274406431.175923] [nm-netlink-monitor.c:117] link_msg_handler(): netlink link message: iface idx 40 flags 0x80
NetworkManager[25660]: <debug> [1274406431.176017] [nm-netlink-monitor.c:117] link_msg_handler(): netlink link message: iface idx 70 flags 0x1002
NetworkManager[25660]: <debug> [1274406431.176118] [nm-netlink-monitor.c:117] link_msg_handler(): netlink link message: iface idx 71 flags 0x1003
NetworkManager[25660]: <debug> [1274406431.176707] [nm-supplicant-interface.c:811] nm_supplicant_interface_add_cb(): (wlan1): interface added to supplicant
NetworkManager[25660]: <debug> [1274406431.177006] [nm-supplicant-interface.c:811] nm_supplicant_interface_add_cb(): (wlan0): interface added to supplicant
NetworkManager[25660]: <info> (wlan1): supplicant interface state:  starting -> ready
NetworkManager[25660]: <info> (wlan1): device state change: 2 -> 3 (reason 42)
NetworkManager[25660]: <info> (wlan0): supplicant interface state:  starting -> ready
NetworkManager[25660]: <info> (wlan0): device state change: 2 -> 3 (reason 42)
GSlice: MemChecker: attempt to release block with invalid size: 0x7be690 size=8 invalid-size=16
NetworkManager[25660]: <warn> caught signal 6. Generating backtrace...
NetworkManager: ******************* START **********************************
NetworkManager: [Thread debugging using libthread_db enabled]
NetworkManager: 0x000000315e00ef9e in __libc_waitpid (pid=<value optimized out>, stat_loc=
NetworkManager:     0x7fff9c5324bc, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
NetworkManager: 32	      return INLINE_SYSCALL (wait4, 4, pid, stat_loc, options, NULL);
NetworkManager: #0  0x000000315e00ef9e in __libc_waitpid (pid=<value optimized out>, stat_loc=
NetworkManager:     0x7fff9c5324bc, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
NetworkManager: #1  0x000000000045143b in nm_logging_backtrace ()
NetworkManager: #2  0x000000000043d059 in ?? ()
NetworkManager: #3  <signal handler called>
NetworkManager: #4  0x000000315d4329c5 in raise (sig=6)
NetworkManager:     at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
NetworkManager: #5  0x000000315d4341a5 in abort () at abort.c:92
NetworkManager: #6  0x000000315ec5a9a8 in IA__g_slice_free1 (mem_size=16, mem_block=0x7be690)
NetworkManager:     at gslice.c:871
NetworkManager: #7  0x000000000044704a in ?? ()
NetworkManager: #8  0x0000003167c0db53 in d_pending_call_free (data=0x7ee920)
NetworkManager:     at dbus-gproxy.c:1780
NetworkManager: #9  0x000000316382520d in _dbus_data_slot_list_clear (list=0x7eeda8)
NetworkManager:     at dbus-dataslot.c:333
NetworkManager: #10 0x0000003163825249 in _dbus_data_slot_list_free (list=0x7eeda8)
NetworkManager:     at dbus-dataslot.c:350
NetworkManager: #11 0x000000316381d7a6 in _dbus_pending_call_last_unref (pending=0x7eeda0)
NetworkManager:     at dbus-pending-call.c:393
NetworkManager: #12 0x000000316381073f in dbus_connection_dispatch (connection=0x78dbb0)
NetworkManager:     at dbus-connection.c:4397
NetworkManager: #13 0x0000003167c09a25 in message_queue_dispatch (
NetworkManager:     source=<value optimized out>, callback=<value optimized out>, 
NetworkManager:     user_data=<value optimized out>) at dbus-gmain.c:101
NetworkManager: #14 0x000000315ec3bd02 in g_main_dispatch (context=0x78ac30) at gmain.c:1960
NetworkManager: #15 IA__g_main_context_dispatch (context=0x78ac30) at gmain.c:2513
NetworkManager: #16 0x000000315ec3fae8 in g_main_context_iterate (context=0x78ac30, block=1, 
NetworkManager:     dispatch=1, self=<value optimized out>) at gmain.c:2591
NetworkManager: #17 0x000000315ec3fff5 in IA__g_main_loop_run (loop=0x78ad70) at gmain.c:2799
NetworkManager: #18 0x000000000043e374 in main ()
NetworkManager: 
NetworkManager: Thread 1 (Thread 0x7f30c3c0f7e0 (LWP 25660)):
NetworkManager: #0  0x000000315e00ef9e in __libc_waitpid (pid=<value optimized out>, stat_loc=
NetworkManager:     0x7fff9c5324bc, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
NetworkManager: 18446744073709551104
NetworkManager:         oldtype = <value optimized out>
NetworkManager:         result = <value optimized out>
NetworkManager: #1  0x000000000045143b in nm_logging_backtrace ()
NetworkManager: No symbol table info available.
NetworkManager: #2  0x000000000043d059 in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #3  <signal handler called>
NetworkManager: No symbol table info available.
NetworkManager: #4  0x000000315d4329c5 in raise (sig=6)
NetworkManager:     at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
NetworkManager: 0
NetworkManager: 25660
NetworkManager: 25660
NetworkManager: #5  0x000000315d4341a5 in abort () at abort.c:92
NetworkManager: 2
NetworkManager:         act = {__sigaction_handler = {sa_handler = 0x7fff9c532980, 
NetworkManager: 
NetworkManager: 4294967295, 
NetworkManager: 1560338176, 
NetworkManager: 0x1}
NetworkManager: 0 <repeats 15 times>}}
NetworkManager: #6  0x000000315ec5a9a8 in IA__g_slice_free1 (mem_size=16, mem_block=0x7be690)
NetworkManager:     at gslice.c:871
NetworkManager: 16
NetworkManager: 1
NetworkManager: #7  0x000000000044704a in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #8  0x0000003167c0db53 in d_pending_call_free (data=0x7ee920)
NetworkManager:     at dbus-gproxy.c:1780
NetworkManager:         closure = 0x7ee920
NetworkManager: #9  0x000000316382520d in _dbus_data_slot_list_clear (list=0x7eeda8)
NetworkManager:     at dbus-dataslot.c:333
NetworkManager:         i = <value optimized out>
NetworkManager: #10 0x0000003163825249 in _dbus_data_slot_list_free (list=0x7eeda8)
NetworkManager:     at dbus-dataslot.c:350
NetworkManager: No locals.
NetworkManager: #11 0x000000316381d7a6 in _dbus_pending_call_last_unref (pending=0x7eeda0)
NetworkManager:     at dbus-pending-call.c:393
NetworkManager:         connection = 0x78dbb0
NetworkManager: #12 0x000000316381073f in dbus_connection_dispatch (connection=0x78dbb0)
NetworkManager:     at dbus-connection.c:4397
NetworkManager:         message = 0x7ee410
NetworkManager:         link = <value optimized out>
NetworkManager:         filter_list_copy = <value optimized out>
NetworkManager:         message_link = 0x7b86f0
NetworkManager: DBUS_HANDLER_RESULT_NOT_YET_HANDLED
NetworkManager:         pending = <value optimized out>
NetworkManager:         reply_serial = <value optimized out>
NetworkManager:         status = <value optimized out>
NetworkManager: "dbus_connection_dispatch"
NetworkManager: #13 0x0000003167c09a25 in message_queue_dispatch (
NetworkManager:     source=<value optimized out>, callback=<value optimized out>, 
NetworkManager:     user_data=<value optimized out>) at dbus-gmain.c:101
NetworkManager:         connection = 0x78dbb0
NetworkManager: #14 0x000000315ec3bd02 in g_main_dispatch (context=0x78ac30) at gmain.c:1960
NetworkManager:         dispatch = 0x3167c09a10 <message_queue_dispatch>
NetworkManager: 0
NetworkManager:         user_data = 0x0
NetworkManager:         callback = 0
NetworkManager:         cb_funcs = 0x0
NetworkManager:         cb_data = 0x0
NetworkManager: 0x0}
NetworkManager:         need_destroy = <value optimized out>
NetworkManager:         source = 0x78f9b0
NetworkManager:         current = 0x780ac0
NetworkManager:         i = <value optimized out>
NetworkManager: #15 IA__g_main_context_dispatch (context=0x78ac30) at gmain.c:2513
NetworkManager: No locals.
NetworkManager: #16 0x000000315ec3fae8 in g_main_context_iterate (context=0x78ac30, block=1, 
NetworkManager:     dispatch=1, self=<value optimized out>) at gmain.c:2591
NetworkManager: 0
NetworkManager: 0
NetworkManager: 1
NetworkManager: 7
NetworkManager:         allocated_nfds = <value optimized out>
NetworkManager:         fds = <value optimized out>
NetworkManager: "g_main_context_iterate"
NetworkManager: #17 0x000000315ec3fff5 in IA__g_main_loop_run (loop=0x78ad70) at gmain.c:2799
NetworkManager:         self = 0x773300
NetworkManager: "IA__g_main_loop_run"
NetworkManager: #18 0x000000000043e374 in main ()
NetworkManager: No symbol table info available.
NetworkManager: A debugging session is active.
NetworkManager: 
NetworkManager: 	Inferior 1 [process 25660] will be detached.
NetworkManager: 
NetworkManager: Quit anyway? (y or n) [answered Y; input not from terminal]
NetworkManager: ******************* END **********************************

Version-Release number of selected component (if applicable):

NetworkManager-0.8.1-0.1.git20100510.fc13.x86_64

How reproducible:

100%

Steps to Reproduce:
1. NetworkManager --no-daemon --log-level=DEBUG
  
Actual results:

crash

Expected results:

no crash

Additional info:

Works ok in normal operation.
Comment 1 Dan Williams 2010-05-22 12:45:12 EDT
Is this easily reproducible?  If so, any chance you can valgrind it?  Though since this happens in dbus-glib, it's likely a race of some kind that valgrind would confuse.
Comment 2 Dan Williams 2011-01-11 10:17:22 EST
Likely long fixed; haven't seen issues with --log-level for a while.

Note You need to log in before you can comment on or make changes to this bug.