Bug 594684 - display-properties fails to recognize ext display during sleep-wake
Summary: display-properties fails to recognize ext display during sleep-wake
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard: card_965GM
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 10:34 UTC by Chris Ward
Modified: 2010-11-11 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-11 16:31:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
xorg log (83.11 KB, text/plain)
2010-05-25 08:42 UTC, Chris Ward
no flags Details
dmesg (110.83 KB, text/plain)
2010-05-25 08:42 UTC, Chris Ward
no flags Details
messages (257.14 KB, text/plain)
2010-05-25 08:43 UTC, Chris Ward
no flags Details

Description Chris Ward 2010-05-21 10:34:39 UTC
I'm running T61

lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev ff)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)


Steps to Reproduce:
1. boot system un-docked. 
2. Log-in
3. sleep system
4. wake-up system
5. once screen-saver prompts for password, dock system
  
Actual results:
after typing in password, it's clear that the external screen wasn't recognized

Expected results:
external screen would be available

Additional info:
by opening display-properties manually, the screen is probed and recognized. But this shouldn't be necessary.

Comment 1 RHEL Program Management 2010-05-21 10:35:54 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Bastien Nocera 2010-05-21 13:20:54 UTC
The driver is responsible for probing outputs.

Comment 3 Matěj Cepl 2010-05-24 19:15:35 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command,
* system log (/var/log/messages), and
* X server log file (/var/log/Xorg.*.log)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Chris Ward 2010-05-25 08:41:19 UTC
(In reply to comment #3)
> Thanks for the bug report.  We have reviewed the information you have provided
> above, and there is some additional information we require that will be helpful
> in our diagnosis of this issue.
> 
> Please add drm.debug=0x04 to the kernel command line, restart computer, and
> attach

Done. Attaching logs now. These are clean logs. I have not attempted to crash the system or anything. Just set the debug flag, restarted the system and logged into gnome.

> 
> * your X server config file (/etc/X11/xorg.conf, if available),

Non-available

> * output of the dmesg command,

ATTACHED.

> * system log (/var/log/messages), and

ATTACHED.

> * X server log file (/var/log/Xorg.*.log)

ATTACHED.

> 
> to the bug report as individual uncompressed file attachments using the
> bugzilla file attachment link above.
> 
> We will review this issue again once you've had a chance to attach this
> information.
> 
> Thanks in advance.

Comment 5 Chris Ward 2010-05-25 08:42:15 UTC
Created attachment 416316 [details]
xorg log

Comment 6 Chris Ward 2010-05-25 08:42:54 UTC
Created attachment 416317 [details]
dmesg

Comment 7 Chris Ward 2010-05-25 08:43:11 UTC
Created attachment 416318 [details]
messages

Comment 9 Chris Ward 2010-05-25 08:50:44 UTC
Sorry, ignore comment #8... I thought this was a different bug. Comment #0 should describe the proper reproduction steps....

Comment 12 Dave Airlie 2010-06-24 01:41:00 UTC
can we get a test with a newer kernel? we've changed the display probing in later kernels.

Comment 13 Chris Ward 2010-06-24 09:05:55 UTC
I'll test today, hopefully, running 2.6.32-36.el6.x86_64 and report back.

Comment 14 Chris Ward 2010-06-25 10:49:58 UTC
Seems to be working now! Great! I'll report back if i see this issue again.

Comment 15 releng-rhel@redhat.com 2010-11-11 16:31:04 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.