Bug 594781 - problem with different alert volume
problem with different alert volume
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Jaroslav Kysela
Red Hat Kernel QE team
:
Depends On: 583476
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 11:19 EDT by Michal Haško
Modified: 2015-03-01 22:59 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 583476
Environment:
Last Closed: 2012-07-10 14:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Haško 2010-05-21 11:19:16 EDT
+++ This bug was initially created as a clone of Bug #583476 +++

Description of problem:

There is a setting to set different alert volume than rest of the sounds (music, video ...).

But when alert occurs rest of the sounds is inheriting the sound volume from the alert (only for the time of life of alert sound).


Version-Release number of selected component (if applicable):


pulseaudio-utils-0.9.21-6.fc13.i686
pulseaudio-libs-0.9.21-6.fc13.i686
pulseaudio-module-gconf-0.9.21-6.fc13.i686
alsa-plugins-pulseaudio-1.0.22-1.fc13.i686
pulseaudio-module-x11-0.9.21-6.fc13.i686
pulseaudio-module-bluetooth-0.9.21-6.fc13.i686
pulseaudio-libs-glib2-0.9.21-6.fc13.i686
pulseaudio-0.9.21-6.fc13.i686
pulseaudio-gdm-hooks-0.9.21-6.fc13.i686

gstreamer-plugins-bad-free-0.10.18-2.fc13.i686
gstreamer-plugins-good-0.10.21-2.fc13.i686
PackageKit-gstreamer-plugin-0.6.3-1.fc13.i686
gstreamer-plugins-base-0.10.28-1.fc13.i686
gstreamer-tools-0.10.28-2.fc13.i686
gstreamer-rtsp-0.10.5-1.fc13.i686
gstreamer-0.10.28-2.fc13.i686
gstreamer-python-0.10.16-1.fc12.i686
fluendo-codecs-complete-bundle-11-4.i386

uname -a
Linux smatbook.setuid.cc 2.6.33.1-24.fc13.i686.PAE #1 SMP Tue Mar 30 18:26:25 UTC 2010 i686 i686 i386 GNU/Linux




How reproducible:


Steps to Reproduce:
1. Set volume of alerts higher than rest of the sounds (Sound preferences/Sound Effects/Alert volume)

2. Launch application like pidgin (in my case) and send/receive message with sounds alerts turned on.
  
Actual results:
non-alert music is having sound volume level  equal to the alert one for the time of the alert, then returns back to normal.

Expected results:

Music will have still the same sound volume level during alert sound.

Additional info:

tested setup:

pidgin-2.6.6-2.fc13.i686
rhythmbox-0.12.8-3.fc13.i686

--- Additional comment from lpoetter@redhat.com on 2010-04-18 15:31:17 EDT ---

This is a problem of incorrect dB information exported by your audio driver. It neesd to be fixed in the driver. For more information see:

http://pulseaudio.org/wiki/BadDecibel

Reasigning to kernel.

Please attach the output of alsa-info.sh --no-upload here, as well as the measurements suggested in the wiki page linked above.

--- Additional comment from setuid@setuid.cc on 2010-04-18 16:20:54 EDT ---

Created an attachment (id=407447)
alsa-info.sh --no-upload

--- Additional comment from setuid@setuid.cc on 2010-04-18 16:30:54 EDT ---

Info about sound device:


bash-4.1$ cat /proc/asound/cards 
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xee240000 irq 30
29 [ThinkPadEC     ]: ThinkPad EC - ThinkPad Console Audio Control
                      ThinkPad Console Audio Control at EC reg 0x30, fw 7BHT40WW-1.13



bash-4.1$ amixer -D hw:Intel | grep "Simple mixer control"
Simple mixer control 'Master',0
Simple mixer control 'PCM',0
Simple mixer control 'CD',0
Simple mixer control 'Mic',0
Simple mixer control 'Mic Boost',0
Simple mixer control 'IEC958',0
Simple mixer control 'IEC958 Default PCM',0
Simple mixer control 'IEC958 Playback Source',0
Simple mixer control 'Beep',0
Simple mixer control 'Capture',0
Simple mixer control 'Mix',0

bash-4.1$ amixer -D hw:ThinkPadEC 
Simple mixer control 'Console',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 14
  Mono: Playback 9 [64%] [on]
bash-4.1$ amixer -D hw:Intel 
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 63
  Mono:
  Front Left: Playback 35 [56%] [-39.00dB] [on]
  Front Right: Playback 35 [56%] [-39.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 23 [74%] [0.00dB] [on]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive penum
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 23 [74%] [0.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive penum
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [on]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%]
  Front Right: 0 [0%]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Playback Source',0
  Capabilities: enum
  Items: 'PCM' 'ADC'
  Item0: 'PCM'
Simple mixer control 'Beep',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 0 [0%] [-45.00dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 8 [53%] [12.00dB] [on]
  Front Right: Capture 8 [53%] [12.00dB] [on]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive penum
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Comment 2 RHEL Product and Program Management 2010-06-07 12:08:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2010-07-15 10:45:46 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 RHEL Product and Program Management 2011-10-07 11:03:54 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Jaroslav Kysela 2012-07-10 14:58:03 EDT
The HDA codec specification handles the dB ranges. These ranges are exposed from the driver to the user space without any modifications. The reason of this issue can be, that the hardware vendors do not follow specs.

As Lennart noted, use the dbmeasure tool to measure the real dB levels:

http://pulseaudio.org/wiki/BadDecibel

To add some dB quirks for broken hardware, this information is required:

1) output from 'alsa-info.sh --no-upload'
2) dbmeasure output

Please, open a new bug for each affected hardware. Closing as deferred for the time.

Note You need to log in before you can comment on or make changes to this bug.