Bug 59490 - SIGILL during Xserver startup
SIGILL during Xserver startup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 16:37 EST by Richard Henderson
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 05:00:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xserver startup log (17.04 KB, text/plain)
2002-02-08 16:38 EST, Richard Henderson
no flags Details
gdb session (639 bytes, text/plain)
2002-02-08 16:40 EST, Richard Henderson
no flags Details

  None (edit)
Description Richard Henderson 2002-02-08 16:37:08 EST
Description of problem:
On PC164 with Elsa Permedia2, the X server crashes during startup.
Logs to be attached.

Version-Release number of selected component (if applicable):
XFree86-4.1.0-15

How reproducible:
Always

Steps to Reproduce:
X

Additional info:
Twice I've seen /usr/X11R6/lib/modules/libramdac.a get corrupted
in the process.  This aspect I don't understand, since strace shows
that the file was indeed opened O_RDONLY.  Perhaps it's related to
the kernel version -- not all bugfixes for PC164 were included before
2.4.15, so I cannot run a stock 2.4.9-21 kernel.  Presently running
2.4.18-pre9.
Comment 1 Richard Henderson 2002-02-08 16:38:15 EST
Created attachment 45017 [details]
Xserver startup log
Comment 2 Richard Henderson 2002-02-08 16:40:19 EST
Created attachment 45018 [details]
gdb session
Comment 3 Mike A. Harris 2002-02-08 18:10:01 EST
Reassigning to alpha development group.
Comment 4 Mike A. Harris 2002-02-09 17:32:46 EST
no, really this time.  promise.
Comment 5 Beth Uptagrafft 2002-02-14 12:45:12 EST
This case was filed against 7.1, is this correct?  Does this happen on 7.1 or 
7.2?
Comment 6 Richard Henderson 2002-02-14 12:56:41 EST
It's really 7.1 with all updates installed.
Comment 7 Mike A. Harris 2002-11-08 10:16:13 EST
Reassigning...
Comment 8 Mike A. Harris 2002-11-08 10:17:37 EST
>(II) GLINT(0): Not using default mode "1920x1440" (bad mode
>clock/interlace/doublescan)
>
>Fatal server error:
>Caught signal 4.  Server aborting

SIGILL is generally a case of bad memory, overheating or some other
hardware issue.  Does this problem persist still?

If so, have you also tried RHL 7.2/Alpha?

Can you test the memory in this machine for failure?
Comment 9 Richard Henderson 2002-11-08 14:08:09 EST
SIGILL on Alpha is generally a case of compiling code for a newer ISA
and running it on a machine that only supports an older ISA.

RHL 7.2/Alpha isn't.  There are no generally available ISOs, there is
no published security errata.  Despite the fact that we gave a cd to
Compaq, IMO it isn't a real release.

All that said, the problems went away with XFree86-4.1.0-25.
Comment 10 Mike A. Harris 2002-12-19 05:00:42 EST
Ok, cool, closing CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.