Bug 595016 - [abrt] crash in glabels-2.2.7-1.fc13: gl_view_text_init: Process /usr/bin/glabels was killed by signal 8 (SIGFPE)
Summary: [abrt] crash in glabels-2.2.7-1.fc13: gl_view_text_init: Process /usr/bin/gla...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glabels   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:410ddfa3d17c73a9f3009184b92...
Keywords:
: 590496 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-22 20:53 UTC by Jeff Schroeder
Modified: 2010-05-27 18:33 UTC (History)
3 users (show)

Fixed In Version: glabels-2.2.8-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 18:33:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.61 KB, text/plain)
2010-05-22 20:53 UTC, Jeff Schroeder
no flags Details

Description Jeff Schroeder 2010-05-22 20:53:33 UTC
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: glabels
component: glabels
crash_function: gl_view_text_init
executable: /usr/bin/glabels
global_uuid: 410ddfa3d17c73a9f3009184b92f48bf41ac28b7
kernel: 2.6.33.3-85.fc13.i686
package: glabels-2.2.7-1.fc13
rating: 4
reason: Process /usr/bin/glabels was killed by signal 8 (SIGFPE)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Open glabels
2. Create a new document and use the Avery 5388 Index Cards template
2. Click the text tool
3. Click on the document and then move the mouse

Comment 1 Jeff Schroeder 2010-05-22 20:53:35 UTC
Created attachment 415891 [details]
File: backtrace

Comment 2 JR 2010-05-23 23:35:50 UTC
*** Bug 590496 has been marked as a duplicate of this bug. ***

Comment 3 Jef Spaleta 2010-05-24 18:09:52 UTC
Jeff,

I'm going to roll a glabels 2.2.8 package to see if this fixes the problem. Would you be willing to test it asap?

-jef

Comment 4 Jef Spaleta 2010-05-24 19:26:11 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=2206609

I believe 2.2.8 fixes the issue for me. Please test the packages from koji asap.

Comment 5 Fedora Update System 2010-05-24 22:17:55 UTC
glabels-2.2.8-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/glabels-2.2.8-1.fc13

Comment 6 Jeff Schroeder 2010-05-25 00:54:52 UTC
Thankyou for the quick turn around. Your new package from koji fixes the problem.

-SEJeff from all of your favorite forums like lwn

Comment 7 Jef Spaleta 2010-05-25 17:05:38 UTC
Jeff,
Do me a favor and add some karma to the bodhi update ticket url in comment 5

Comment 8 Fedora Update System 2010-05-25 18:36:31 UTC
glabels-2.2.8-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glabels'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/glabels-2.2.8-1.fc13

Comment 9 Fedora Update System 2010-05-27 18:33:45 UTC
glabels-2.2.8-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.