Bug 595095 - udev sometimes gets stuck in a loop looking for md RAID devices
udev sometimes gets stuck in a loop looking for md RAID devices
Status: CLOSED DUPLICATE of bug 586592
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mdadm (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Doug Ledford
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-23 06:51 EDT by Gordan Bobic
Modified: 2010-07-22 13:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 13:18:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordan Bobic 2010-05-23 06:51:07 EDT
Description of problem:
Approximately half the time, udev hangs for a long time at startup, and eventually produces many messages like this before eventually timing out:

  /sys/devices/virtual/block/md126 (10745)
  /sys/devices/virtual/block/md127 (10746)
  /sys/devices/virtual/block/md126 (10747)
  /sys/devices/virtual/block/md127 (10748)
  /sys/devices/virtual/block/md126 (10749)
  /sys/devices/virtual/block/md127 (10750)
  /sys/devices/virtual/block/md126 (10751)
  /sys/devices/virtual/block/md127 (10752)
  /sys/devices/virtual/block/md126 (10753)
Wait timeout. Will continue in the background.             [FAILED]


Version-Release number of selected component (if applicable):
udev-151-7.fc13.x86_64
libudev-147-2.6.el6.x86_64
kernel-2.6.32-19.el6.x86_64

How reproducible:
Approximately 50% of the time.

Steps to Reproduce:
1. Set up rootfs on md RAID5
2. Reboot
  
Actual results:
udev startup stops until timeout.

Expected results:
Fast startup without timeouts and error messages.
Comment 2 RHEL Product and Program Management 2010-06-07 12:12:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2010-07-15 10:52:06 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Doug Ledford 2010-07-22 13:18:33 EDT

*** This bug has been marked as a duplicate of bug 586592 ***

Note You need to log in before you can comment on or make changes to this bug.