Bug 59511 - Network printing broken after applying updates
Network printing broken after applying updates
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 20:02 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 12:22:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
workstation printcap (778 bytes, text/plain)
2002-02-12 05:40 EST, Need Real Name
no flags Details
Requested file (541 bytes, text/plain)
2002-02-14 16:30 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-02-08 20:02:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020201

Description of problem:
Cant print with Epson 660 parallel printer after applying updates. Selected
ghostscript
print driver and no output at all. Selected stp print driver and there was only
garbage printed (various resolutions). Selected Omni print driver, only garbage
printed (various resolutions). 
This printer worked before the updates and with redhat 7.1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.select printer/driver in printconf-gui
2.apply
3.print test page
	

Actual Results:  either nothing or garbage

Expected Results:  test page printed

Additional info:
Comment 1 Tim Waugh 2002-02-11 10:28:12 EST
Oh, bad.  Which packages did you have installed when this last worked: were they
from the CD, or from a previous update?
Comment 2 Need Real Name 2002-02-12 05:24:20 EST
I have a server (200 mmx i586) with the printer. After further experimentation I
can now print with this printer using the stp driver on the server. 

My workstation (800 celeron) cannot print using any driver (using a remote lpd
queue). Oddly enough this is the reverse of before the patches. I applied the
patches from the mirror site mirror.aarnet.edu.au. 

Having reflected on the problem I now also remember that I applied the ximian
packages after being able to sucessfully print. Browsing the ximian packages I
can see no packages that leap out and say "I broke your printing". I am
attempting to print just the a4 test page
.
Comment 3 Need Real Name 2002-02-12 05:40:36 EST
Created attachment 45379 [details]
workstation printcap
Comment 4 Tim Waugh 2002-02-12 10:05:41 EST
Please attach the /etc/alchemist/namespace/printconf/local.adl file from the
workstation.
Comment 5 Need Real Name 2002-02-14 16:30:26 EST
Created attachment 45739 [details]
Requested file
Comment 6 Need Real Name 2002-02-14 16:36:45 EST
My email is currently broken ( i have moved to a adsl account). Printing is
still broken but I am currently downloading the most recent foomatic available
via ximian updates .

foomatic-1.1-0.20011218.3.i386.rpm
printconf-0.3.61-3.i386.rpm
printconf-gui-0.3.61-3.i386.rpm

I will let you know.

Cheers
Comment 7 Need Real Name 2002-02-19 16:43:44 EST
Email working again. Printing still broken after updating rpms :-(
Comment 8 Tim Waugh 2002-02-22 09:29:46 EST
Is the 'epson' printer queue on the server set up as a raw queue?  Please attach
its local.adl.

I think what you want to do is set up the server so that it's queue accepts
PostScript, and set up the workstation so that it uses a Postscript network
printer.  The machines talk Postscript to each other, and the server converts it
to 'Epson language'.

Note You need to log in before you can comment on or make changes to this bug.