Bug 59514 - Generalize '%ifarch i386' statement
Generalize '%ifarch i386' statement
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: telnet (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 20:28 EST by Enrico Scholz
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 06:55:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-02-08 20:28:34 EST
Description of Problem:

telnet.spec contains:

| # XXX hack around gcc-2.96 problem
| %ifarch i386
| export RPM_OPT_FLAGS="`echo $RPM_OPT_FLAGS | sed -e s/-O2/-O0/`"
| %endif

Since the mentioned problem exists in a build for other ix86-platforms probably
also (or  disappeared in the meantime), the '%ifarch i386' statement should be
replaced by the more general

| %ifarch %{ix86}

(or removed entirely)


Version-Release number of selected component (if applicable):

telnet-0.17-21.src.rpm
Comment 1 Harald Hoyer 2002-07-09 11:00:12 EDT
yep, thx..

Note You need to log in before you can comment on or make changes to this bug.