Bug 595264 - [virt-v2v] the board name of video driver incorrect in xorg.conf
Summary: [virt-v2v] the board name of video driver incorrect in xorg.conf
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
(Show other bugs)
Version: 5.7
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 08:42 UTC by Mohua Li
Modified: 2013-04-30 23:13 UTC (History)
7 users (show)

Fixed In Version: virt-v2v-0.6.3-1.el5
Doc Type: Bug Fix
Doc Text:
Previously, virt-v2v did not update the board name in xorg.conf when the video driver of a converted Red Hat Enterprise Linux guest was updated. This issue is resolved and no further problems occur when video drivers are updated.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 18:28:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.72 KB, text/plain)
2010-05-24 08:44 UTC, Mohua Li
no flags Details
xorg.conf before conversion (588 bytes, text/plain)
2010-10-25 13:04 UTC, Rita Wu
no flags Details
ESX4.0-RHEL5.5-64b trace log (24.50 KB, text/plain)
2010-10-25 13:06 UTC, Rita Wu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0147 normal SHIPPED_LIVE virt-v2v and libguestfs bug fix update 2011-01-13 18:28:09 UTC

Description Mohua Li 2010-05-24 08:42:54 UTC
Description of problem:

in some guest which is converted by virt-v2v, the board name incorrect like below,this issue mostly happened in rhel3.9/rhel4.8 guest(vm),for example, the ESX3.5-rhel4.8 32bit/64bit guest,

Section "Device"

    Identifier  "Videocard0"

    Driver      "cirrus"

    VendorName  "Videocard vendor"

    BoardName   "VMWare"

EndSection


Version-Release number of selected component (if applicable):
virt-v2v-0.6.0,

How reproducible:
always

Steps to Reproduce:
1,convert the ESX/kvm/xen guest to ovf output by virt-v2v like below,
virt-v2v -f $config  -ic esx://10.66.65.108/?no_verify=1  -o rhev -osd  $export ESX4.0-RHEL4.8-i386
2,import the vm in rhevm,
3,check the /etc/X11/xorg.conf(XF86config),

Actual results:
the board name is incorrect

Expected results:


Additional info:

Comment 1 Mohua Li 2010-05-24 08:44:08 UTC
Created attachment 416059 [details]
xorg.conf

Comment 2 RHEL Product and Program Management 2010-09-05 07:57:31 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 3 RHEL Product and Program Management 2010-09-06 09:57:13 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2010-09-07 11:57:18 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 5 Matthew Booth 2010-09-13 13:30:53 UTC
Posted here: http://www.redhat.com/archives/libguestfs/2010-September/msg00012.html

Comment 7 koka xiong 2010-10-09 01:59:19 UTC
Verified with virt-v2v-0.6.3-2.el5
1.run virt-v2v -ic esx://10.66.72.149/?no_verify=1 -o rhev -osd 10.66.90.115:/vol/v2vrwu1/xen_export ESX4.0-RHEL4.8-32b
2.Import into rhevm
3.cat /etc/X11/xorg.conf

Section "Device"

    Identifier  "Videocard0"

    Driver      "cirrus"

EndSection

Comment 8 Rita Wu 2010-10-25 13:04:33 UTC
Created attachment 455530 [details]
xorg.conf before conversion

xorg.conf after ESX4.0-RHEL5u5-64bit conversion

# cat /etc/X11/xorg.conf
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "vmware"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Comment 9 Rita Wu 2010-10-25 13:06:03 UTC
Created attachment 455531 [details]
ESX4.0-RHEL5.5-64b trace log

Still 'vmware' after conversion ESX4.0-RHEL5.5-64b

Comment 10 Florian Nadge 2011-01-12 17:21:19 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, virt-v2v did not update the board name in xorg.conf when the video driver of a converted Red Hat Enterprise Linux guest was updated. This issue is resolved and no further problems occur when video drivers are updated.

Comment 12 errata-xmlrpc 2011-01-13 18:28:31 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0147.html


Note You need to log in before you can comment on or make changes to this bug.