Bug 595266 - gstreamer-devel contains a library
Summary: gstreamer-devel contains a library
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gstreamer
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Benjamin Otte
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
: 604566 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 08:44 UTC by Daniel Mach
Modified: 2010-06-16 09:04 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-26 08:58:30 UTC


Attachments (Terms of Use)

Description Daniel Mach 2010-05-24 08:44:19 UTC
gstream-devel contains libgstcheck-0.10.so.0.23.0 and libgstcheck-0.10.so.0 symlink.
I believe they belong to -libs subpackage.

Comment 1 RHEL Product and Program Management 2010-05-24 08:46:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Benjamin Otte 2010-05-26 08:58:30 UTC
libgstcheck is a helper library intended solely for build-testing. The various gstreamer plugin packages would need it when building - or better: running make check - for example.
No installed application would ever depend on it though. Also, the library does not conform to usual quality norms (like proper symbol prefixing). So it makes a lot of sense to only ship it in the devel package.

Comment 3 Benjamin Otte 2010-06-16 09:04:50 UTC
*** Bug 604566 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.