Bug 595427 - RFE: 'virsh list' should output more information like 'xm list'.
Summary: RFE: 'virsh list' should output more information like 'xm list'.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt   
(Show other bugs)
Version: 5.6
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 15:21 UTC by Kirby Zhou
Modified: 2011-08-15 20:05 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-15 20:05:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kirby Zhou 2010-05-24 15:21:14 UTC
Description of problem:

'virsh list' should output more information 'xm list'.
It is very useful for administrators to quick detect where is the problem.


Expected results:

1. the amount of memory used by guest, and maxmem
2. vcpu count
3. uptime of guest
4. More Info such as CPU usage and IOPS of block devices.

for example:
Id Name       State        Memory   VCPU     Uptime    CPU   IOPS
---------------------------------- 
  1 bbs       idle         768M      2       3hours     5%   12.1
  2 bbs2      idle         768M      4      10hours    12%    0.3

5. add an option to find out autostart enabled guests.

Thanks

Comment 1 Jiri Denemark 2010-09-02 11:56:20 UTC
Fixed in libvirt-0.8.2-1.el5

Comment 3 weizhang 2010-10-25 04:58:12 UTC
# virsh list
 Id Name                 State
----------------------------------
  0 Domain-0             running
  5 windows-mig          idle
  6 windows2             running
  7 windows3             running

rhel5.6
kernel-2.6.18-228.el5xen
libvirt-0.8.2-7.el5
xen-3.0.3-117.el5

So the bug is not fixed. I will reassign it.

Comment 4 Jiri Denemark 2010-10-25 09:50:14 UTC
Oops, I got confused again by the Upstream081 mark. I guess I should have checked such bugs more. This is of course not implemented in libvirt-0.8.1 and it's not even upstream now.

Comment 7 RHEL Product and Program Management 2011-01-11 19:59:05 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 8 RHEL Product and Program Management 2011-01-11 22:59:43 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 11 RHEL Product and Program Management 2011-08-15 20:05:18 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.