Bug 595430 - SELinux is preventing /usr/sbin/usbmuxd "write" access on /var/run/usbmuxd.pid.
SELinux is preventing /usr/sbin/usbmuxd "write" access on /var/run/usbmu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:8f33be07c79...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 11:31 EDT by Richard Ryder
Modified: 2010-05-28 14:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-21.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 14:02:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Ryder 2010-05-24 11:31:33 EDT
Summary:

SELinux is preventing /usr/sbin/usbmuxd "write" access on /var/run/usbmuxd.pid.

Detailed Description:

SELinux denied access requested by usbmuxd. It is not expected that this access
is required by usbmuxd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:usbmuxd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:var_run_t:s0
Target Objects                /var/run/usbmuxd.pid [ file ]
Source                        usbmuxd
Source Path                   /usr/sbin/usbmuxd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           usbmuxd-1.0.4-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-15.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux localhost.localdomain
                              2.6.33.4-95.fc13.i686.PAE #1 SMP Thu May 13
                              05:38:26 UTC 2010 i686 i686
Alert Count                   5
First Seen                    Fri 21 May 2010 03:00:34 PM EDT
Last Seen                     Fri 21 May 2010 05:23:07 PM EDT
Local ID                      5b51b29f-fefa-4483-8ccb-c5fa0fc03eec
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1274476987.82:66): avc:  denied  { write } for  pid=3255 comm="usbmuxd" name="usbmuxd.pid" dev=dm-0 ino=399722 scontext=system_u:system_r:usbmuxd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=file

node=localhost.localdomain type=SYSCALL msg=audit(1274476987.82:66): arch=40000003 syscall=5 success=no exit=-13 a0=804f5e7 a1=41 a2=1a4 a3=804f5e7 items=0 ppid=2760 pid=3255 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="usbmuxd" exe="/usr/sbin/usbmuxd" subj=system_u:system_r:usbmuxd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,usbmuxd,usbmuxd_t,var_run_t,file,write
audit2allow suggests:

#============= usbmuxd_t ==============
allow usbmuxd_t var_run_t:file write;
Comment 1 Daniel Walsh 2010-05-24 12:22:59 EDT
This looks like something new.

chcon -t usbmuxd_var_run_t /var/run/usbmuxd.pid

Should fix.

I will fix default labeling in next release.

Fixed in selinux-policy-3.7.19-21.fc13.noarch
Comment 2 Fedora Update System 2010-05-25 10:36:57 EDT
selinux-policy-3.7.19-21.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-21.fc13
Comment 3 Fedora Update System 2010-05-26 17:46:03 EDT
selinux-policy-3.7.19-21.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-21.fc13
Comment 4 Fedora Update System 2010-05-28 14:01:40 EDT
selinux-policy-3.7.19-21.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.