Bug 59550 - vfree(): sleeping in interrupt with PPP
vfree(): sleeping in interrupt with PPP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 03:05 EST by Pekka Pietikäinen
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 10:35:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2002-02-10 03:05:13 EST
Description of Problem:

When the PPP module gets loaded a kernel traceback gets printed

PPP generic driver version 2.4.1
PPP BSD Compression module registered
PPP Deflate Compression module registered
vfree(): sleeping in interrupt!! 
d2dc1ec0 c0296ec0 d6bbdd3c 00000000 d892d186 d8930000 d8945680 d89271d1 
       d6bbdd3c ffffff97 2d707070 706d6f63 73736572 0036322d d5360254 d531d130 
       08054000 c0119e4b 0018041a 00000003 00000001 c0322080 fffffffe 00000246 
Call Trace: [<d892d186>] __insmod_bsd_comp_S.text_L3216 [bsd_comp] 0x126 
[<d8945680>] z_errmsg [ppp_deflate] 0x40 
[<d89271d1>] ppp_output_wakeup_R1804a995 [ppp_generic] 0x1e1 
[<c0119e4b>] bh_action [kernel] 0x1b 
[<c0119b7b>] do_softirq [kernel] 0x4b 
[<d89247cb>] __insmod_ppp_generic_S.text_L16272 [ppp_generic] 0x76b 
[<c0143907>] sys_ioctl [kernel] 0x217 
[<c0106ecb>] system_call [kernel] 0x33 

Version-Release number of selected component (if applicable):

2.4.17-0.13 (problem did not exist in 7.2 kernels)

How Reproducible:

ifup ppp0
Comment 1 Arjan van de Ven 2002-02-19 13:56:33 EST
This debug assert needs to be fixed... but it's tricky.
(the assert message itself is harmless)
Comment 2 Leonid Kanter 2002-03-11 10:35:04 EST
This bug is still present in 2.4.18-0.1
vfree(): sleeping in interrupt!!
c19edee4 c02995e0 c8b22e20 c8b22f24 cddabce4 cdd9a000 cddaa111 00000000
       cdd9a008 c8b22f24 c8b22e20 c19edf2c c8b22e20 00000000 cdda89a5 c8b22f24
       c8b22e20 c19edf2c 08079bc2 c8b22e0c cddac092 c8b22e20 c75a6e00 cdd7e46b
Call Trace: [<cddabce4>] adler32 [ppp_deflate] 0x184
[<cddaa111>] inflate_blocks_free [ppp_deflate] 0x21
[<cdda89a5>] inflateEnd [ppp_deflate] 0x35
[<cddac092>] adler32 [ppp_deflate] 0x532
[<cdd7e46b>] ppp_output_wakeup_R1804a995 [ppp_generic] 0x43b
[<cdd7b72b>] __insmod_ppp_generic_S.text_L16544 [ppp_generic] 0x6cb
[<c01461c7>] sys_ioctl_Rafb6a3f7 [] 0x217
[<c0108943>] sys_sigaltstack_Rab65536b [] 0xdb3
Comment 3 Pekka Pietikäinen 2002-05-26 08:58:24 EDT
Bug seems to be fixed in the final release so I've closed the bug.

Note You need to log in before you can comment on or make changes to this bug.