Bug 59551 - installer crash when 6 packages left
Summary: installer crash when 6 packages left
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-10 08:12 UTC by Pekka Pietikäinen
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 17:21:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Pietikäinen 2002-02-10 08:12:35 UTC
Description of Problem:

When upgrading from 7.2 -> 7.2.90 the upgrade went mostly ok until
there were just 6 packages left to install. Then the installer crashed
and the system went back to text mode where there were no helpful messages
about the reason of the crash.

upgrade.log ended with 

Upgrading wordtrans-web.
Upgrading Xbae-devel.
Upgrading xcdroast.
Upgrading xfig.

(there should have been a few after that like zsh).

After rebooting the system the rpm database was just like before the
update (== all package versions were the 7.2 ones even though the
packages had been upgraded)

This problem _might_ be related to flaky media, as the cd was in my
dvd drive that had some problems reading the disc3 cd-rw reliably
(my plextor read the disk just fine)

Comment 1 Michael Fulbright 2002-02-11 16:06:46 UTC
Did you run 'linux mediacheck' to test the CDs you burned as directed in the
release notes?

Comment 2 Pekka Pietikäinen 2002-02-25 17:21:15 UTC
I did. Can't remember which drive the cd was in during the media check,
it's been two weeks.  In any case the installer shouldn't crash 
like that, 7.2 at least displayed a dialog that offers a retry possibility.

Comment 3 Jeremy Katz 2002-03-14 23:33:47 UTC
depends on the case in which it crashes... sometimes fall over in levels that
don't pass up errors nicely (*cough* the ide/scsi layers *cough* :) or rpm not
passing back a callback.  I've instrumented a new rpm callback that will
hopefully be in beta3 that will catch some of these things more nicely.

The newer rpmdb is in /var/lib/rpm.rebuilddb* btw


Note You need to log in before you can comment on or make changes to this bug.