Bug 595619 - RHEV cannot start imported guest with multiple disks because more than one is marked as bootable
Summary: RHEV cannot start imported guest with multiple disks because more than one is...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v
Version: 5.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 08:16 UTC by Rita Wu
Modified: 2013-07-03 01:40 UTC (History)
10 users (show)

Fixed In Version: 0.6.0-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-16 15:10:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screen Shot (188.76 KB, image/png)
2010-05-25 08:16 UTC, Rita Wu
no flags Details
log from LIBGUESTFS_TRACE=1 (23.37 KB, text/plain)
2010-05-25 08:17 UTC, Rita Wu
no flags Details
log from virt-inspect before conversion (361.61 KB, text/plain)
2010-05-25 08:17 UTC, Rita Wu
no flags Details
xml file (1.30 KB, text/plain)
2010-05-25 08:18 UTC, Rita Wu
no flags Details
vdsm.log showing failure to start guest. (865.48 KB, text/plain)
2010-05-25 09:19 UTC, Matthew Booth
no flags Details
OVF file written by virt-v2v to export domain (5.82 KB, text/plain)
2010-05-25 09:20 UTC, Matthew Booth
no flags Details
OVF file taken from data domain post-import (5.48 KB, text/plain)
2010-05-25 09:20 UTC, Matthew Booth
no flags Details

Description Rita Wu 2010-05-25 08:16:11 UTC
Created attachment 416304 [details]
Screen Shot

Description of problem:
Before conversion:
# fdisk -l

Disk /dev/hda: 4294 MB, 4294967296 bytes
255 heads, 63 sectors/track, 522 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          13      104391   83  Linux
/dev/hda2              14         522     4088542+  8e  Linux LVM

Disk /dev/hdb: 1048 MB, 1048576000 bytes
255 heads, 63 sectors/track, 127 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1         127     1020096   83  Linux


Version-Release number of selected component (if applicable):
v2v-libvirt-0.8.1-1.el5
virt-v2v-0.6.0-1.el5

How reproducible:
100%

Steps to Reproduce:
1.# LIBGUESTFS_TRACE=1 virt-v2v -f /etc/virt-v2v.conf -i libvirtxml -o rhev -osd
10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_data multi-disk.xml 2>&1 >
xen-rhel55-x86-64-hvm-conversion.log
  
Actual results:
Fail to boot up guest with 2 disks

Expected results:
Boot up successfully

Additional info:

Comment 1 Rita Wu 2010-05-25 08:17:03 UTC
Created attachment 416305 [details]
log from LIBGUESTFS_TRACE=1

Comment 2 Rita Wu 2010-05-25 08:17:52 UTC
Created attachment 416306 [details]
log from virt-inspect before conversion

Comment 3 Rita Wu 2010-05-25 08:18:31 UTC
Created attachment 416307 [details]
xml file

Comment 4 Matthew Booth 2010-05-25 09:19:17 UTC
Created attachment 416331 [details]
vdsm.log showing failure to start guest.

Failure can be seen at 2010-05-25 08:59:19.

Comment 5 Matthew Booth 2010-05-25 09:20:05 UTC
Created attachment 416332 [details]
OVF file written by virt-v2v to export domain

Comment 6 Matthew Booth 2010-05-25 09:20:54 UTC
Created attachment 416333 [details]
OVF file taken from data domain post-import

Comment 7 Matthew Booth 2010-05-25 09:28:53 UTC
Attempting to start this domain results in an immediate error from RHEV. To be clear, it doesn't appear to get far enough to start booting the guest, so the issue is presumably with metadata.

I've attached the vdsm.log showing failure to start (at 2010-05-25 08:59:19). I've also attached the OVF as written by virt-v2v, and the OVF of the domain after import.

I appreciate the underlying cause is likely to be an issue in the output of virt-v2v, or at least require a change there. However, I am not able to debug the RHEV failure to start. Your help is appreciated.

Thanks,

Matt

Comment 8 Rita Wu 2010-05-25 09:33:26 UTC
and related log from vdc.log 
25May 10:14:01 [2224] INFO  - Host fcp2 storage connection was succeeded 

25May 10:14:03 [2224] INFO  - Running command:
HandleVdsCpuFlagsOrClusterChangedCommand

25May 10:14:03 [2224] INFO  - Running command: HandleVdsVersionCommand

25May 10:28:30 [5348] INFO  - Running command: RunVmCommand

25May 10:28:30 [5348] INFO  - CreateVDSCommand
memSize=512,keyboardLayout=en-us,drives=CookComputing.XmlRpc.XmlRpcStruct[],nicModel=pv,display=vnc,vmId=0b7e8cc2-5cd8-4393-8e17-ad9d42287e98,acpiEnable=true,displayNetwork=rhevm,spiceMonitors=1,emulatedMachine=rhel5.5.0,cpuType=qemu64,+sse2,+cx16,kvmEnable=true,smpCoresPerSocket=1,nice=0,boot=c,timeOffset=-25200,vmName=xen-rhel5u4-64b-hv.raw,vmType=kvm,bridge=rhevm,smp=1,tabletEnable=true,spiceSslCipherSuite=DEFAULT,spiceSecureChannels=smain,sinputs,macAddr=00:16:36:13:66:38

25May 10:28:30 [5348] INFO  - IncreasePendingVms::CreateVmIncreasing vds fcp2
pending vcpu count, now 1. Vm: xen-rhel5u4-64b-hv.raw

25May 10:28:35 [5540] INFO  - Running on vds during rerun failed vm: 

25May 10:28:35 [5540] INFO  - vm xen-rhel5u4-64b-hv.raw running in db and not
running in vds - add to rerun treatment. vds fcp2

25May 10:28:35 [5540] ERROR - Rerun vm 0b7e8cc2-5cd8-4393-8e17-ad9d42287e98.
Called from vds fcp2

25May 10:28:35 [5540] INFO  - DecreasePendingVms::Decreasing vds fcp2 pending
vcpu count, now 0. Vm: xen-rhel5u4-64b-hv.raw

Comment 10 Yaniv Kaul 2010-05-25 10:08:47 UTC
(In reply to comment #7)
> Attempting to start this domain results in an immediate error from RHEV. To be
> clear, it doesn't appear to get far enough to start booting the guest, so the
> issue is presumably with metadata.

VDSM log is quite clear about the issue:
Thread-62184::DEBUG::2010-05-25 09:05:06,062::vm::1306::vds.vmlog.0b7e8cc2-5cd8-4393-8e17-ad9d42287e98::qemu stdouterr: qemu: two bootable drives specified




> 
> I've attached the vdsm.log showing failure to start (at 2010-05-25 08:59:19).
> I've also attached the OVF as written by virt-v2v, and the OVF of the domain
> after import.
> 
> I appreciate the underlying cause is likely to be an issue in the output of
> virt-v2v, or at least require a change there. However, I am not able to debug
> the RHEV failure to start. Your help is appreciated.
> 
> Thanks,
> 
> Matt

Comment 11 Matthew Booth 2010-05-25 10:15:08 UTC
Thanks, Yaniv, I missed that. I'll take this back.

Comment 12 Matthew Booth 2010-05-28 09:29:40 UTC
Fixed in 0.6.0-2.

Comment 13 Rita Wu 2010-05-28 13:22:54 UTC
Verified in 0.6.0-2. Now it can start imported guest with multiple disks.

Comment 14 Ludek Smid 2010-07-16 15:10:38 UTC
This issue was already fixed in advisory
http://rhn.redhat.com/errata/RHEA-2010-0495.html


Note You need to log in before you can comment on or make changes to this bug.