Bug 59563 - dhcpcd behavior changed from 7.2?
dhcpcd behavior changed from 7.2?
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-02-10 10:33 EST by Eugene Kanter
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 16:47:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-02-10 10:33:32 EST
Description of Problem:

provided -D version 7.2 dhcpcd sets domainname from "nis-domain" of 7.2 based
dhcp server.

in 7.2.90 it sets domain from "domain-name"

Version-Release number of selected component (if applicable):

dhcpcd-1.3.21pl2-4

How Reproducible:


Steps to Reproduce:
1. add line DHCPCDARGS="-D -H -d" to /etc/sysconfig/network-scripts/ifcfg-eth0
2. ifdown eth0; ifup eth0
3. domainname.

Actual Results:

domain is set from "domain-name"

Expected Results:

domain is set from "nis-domain"

Additional Information:
Comment 1 Elliot Lee 2002-02-10 17:37:24 EST
Given the dhcpcd-1.3.21-noNISfakery.patch that I added in 1.3.21-3, I find it
hard to believe that it is happening in -4. Would it be possible for you to do
some debugging with the source from -4 to verify that it is really using the DNS
domain setting incorrectly on the client side?
Comment 2 Eugene Kanter 2002-02-11 08:35:56 EST
I can only tell you that 7.2 dhcpcd was using "nis-domain" to enter it in
"search" line of /etc/resolv.conf before "domain-name". That was also a
non-desired behaviour but with no catastrofic consequences. I have not yet
checked what is being put in /etc/resolv.conf in 7.2.90.
My "domain-name" and "nis-domain" are very different and NIS domain is in UPPER
CASE. Domainname is definitely been set to "nis-domain" and upper case is
preserved in output of "domainname" command.
Comment 3 Elliot Lee 2002-02-11 12:30:20 EST
Whoa, I'm a little confused here.

When you were talking about 'domainname' I assumed you meant NIS domain name,
since "DNS domain name" has no clear definition on UNIX... Are you talking about
the DNS domain searches in /etc/resolv.conf (in which case I will ask "what
exactly is the bug?") or the NIS domain name (in which case I will ask you to
find out why my patch isn't having any effect).
Comment 4 Eugene Kanter 2002-02-11 12:48:19 EST
Sorry if my comments about resolv.conf confused you.

The original description is correct: NIS client stopped working after upgrade
7.2 to 7.2.90 because dhcpd broadcased "nis-domain" is ignored by dhcpcd and
instead dhcpd broadcasted "domain-name" is used. I have to manually set
domainname to the proper value and restart ypbind every time my system is rebooted.

Are you able to duplicate the problem?
Comment 5 Elliot Lee 2002-02-11 13:53:15 EST
Here, my NIS domain is supposed to be "redhat.com" and DNS search should be
"devel.redhat.com".

resolv.conf gets set up fine, but NIS domain does not get changed - it appears
that there is some mismatch between the ypbind initscripts (which check
/etc/sysconfig/network for the NISDOMAIN) and dhcpcd (which only writes out
/etc/yp.conf and doesn't touch anything else).

The correct solution is a puzzlement...
Comment 6 Elliot Lee 2002-03-08 11:06:04 EST
I have a patch already in 1.3.21pl2-5 that does the setdomainname() - should fix it.
Comment 7 Eugene Kanter 2002-03-09 12:34:50 EST
Upgraded clean 7.2 to beta2. Same problem as beta1.

$ rpm -qa | grep dhcp
dhcpcd-1.3.21pl2-5

# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
DHCPCDARGS="-D -H"


From RH 7.2 based dhcpd.conf
...
option domain-name "DNSDOMAIN.com";
option nis-domain-name "NISDOMAIN.com";
...

After beta2 boot:

# domainname
DNSDOMAIN.com

Should be NISDOMAIN.com as it is currently in RH 7.2
Comment 8 Elliot Lee 2002-03-27 15:00:43 EST
Am I correct in assuming that dhcpcd is actually setting the NIS domain when it
initializes the interface (and it's not just leaving the existing setting intact)?
Comment 9 Eugene Kanter 2002-03-28 10:39:28 EST
you are correct. This is a fresh install and changes to config files are only
those specified above. dhcpcd is actually setting NIS domain, because I did not
modify any other files after fresh install. I am not aware of any other settings.
Comment 10 Elliot Lee 2002-04-15 11:27:38 EDT
Ahahh, dhcpcd sucks. If you don't pass the -D flag, my previous hack patches
will make it do the proper setdomainname.

Since -D is not the default, it's half your fault :) The other half of the
problem is dhcpcd's implementation of the -D option, which needs fixing at a
later date if we still use dhcpcd.
Comment 11 Eugene Kanter 2002-04-15 16:47:17 EDT
Well, I *had* to do "-D" on RedHat 7.2 because I followed man page and it worked
(almost, 99%) the way I wanted. Man page still says that -D is needed.

You are right, beta4 sets nisdomain and domain search path properly out of the
box. I am very pleased. Seems like man page and/or install document needs to be
adjusted appropriately. Someone else might read it and apply -D with wrong results.
Comment 12 Eugene Kanter 2002-06-20 11:38:22 EDT
There is a mismatch between actual behavior of dhcpcd and its manual page. It
has always been a requirement to report problems like this.
What does WONTFIX mean in this case?

Note You need to log in before you can comment on or make changes to this bug.