Bug 59566 - Kernel hang after warm reboot
Kernel hang after warm reboot
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 10:50 EST by Jos Vos
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 19:53:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2002-02-10 10:50:12 EST
After having aborted an installation, the kernel hangs during a reboot (from
bootnet.img), just after it has spawned some messages about USB (that on itself
look pretty normal).  After a cold reboot (reset button), the boot always works
fine.  This is on an i815-based system.
Comment 1 Jos Vos 2002-02-10 18:21:16 EST
Even after a warm reboot following a *successful* installation, the system
hangs, just after it has displayed the init step about USB.  Warm reboots
*afterwards* seem to work ok, so it seems to be the install kernel or Anaconda
that causes this strange behaviour.
Comment 2 Matt Wilson 2002-02-11 12:37:12 EST
Probably kernel-BOOT problem
Comment 3 Jos Vos 2002-03-08 14:32:33 EST
FYI: this problem still appears on Hampton beta2 with kernel 2.4.18-0.1.
Comment 4 Josep L. Guallar-Esteve 2002-03-19 16:23:19 EST
I have a USB amchine. I successfully did installs using USB   
Keyboard and Mouse. Full installs, without crashes. 
 
On boot the Stage 1 (installation), I can see on VC3: 
 
(...) 
* modules to insert cramfs vfat 
* module(s) cramfs vfat not found 
* load module set done 
* modules to insert ide_cd 
* module(s) ide_cd not found 
* load module set done 
* modules to insert sd_mod sr_mod 
* module(s) sd_mod sr_mod not found 
* load module set done 
* looking for usb controllers 
* found USB controller usb-ohci 
* module(s) usb-ohci not found 
* load module set done 
* failed to insert usb module 
* modules to insert hid keybdev scsi_mod usb_storage 
* module(s) hid keybdev not found 
* inserted /tmp/scsi_mod.o 
* inserted /tmp/usb_storage.o 
* load module set done 
(...) 
 
This is rather strange.  
 
Anyway. The installation works OK (installs, boots, works 
after boot) with both USB devices (keyboard, mouse).  
 
Comment 5 Aaron Brown 2002-03-20 09:26:43 EST
I had no problems installing on my i815 system with
USB KB and mouse.  Tried both warm and cold boots.  Both
worked fine.



Comment 6 Josep L. Guallar-Esteve 2002-03-20 09:48:54 EST
I have a USB amchine. I successfully did installs using USB     
Keyboard and Mouse. Full installs, without crashes. Then, the 
machine works OK. It has no i815 though.  
   
As extra information, I noticed the following: 
 
On install, at Stage 1 (first boot), I can see on VC3:   
   
(...)   
* modules to insert cramfs vfat   
* module(s) cramfs vfat not found   
* load module set done   
* modules to insert ide_cd   
* module(s) ide_cd not found   
* load module set done   
* modules to insert sd_mod sr_mod   
* module(s) sd_mod sr_mod not found   
* load module set done   
* looking for usb controllers   
* found USB controller usb-ohci   
* module(s) usb-ohci not found   
* load module set done   
* failed to insert usb module   
* modules to insert hid keybdev scsi_mod usb_storage   
* module(s) hid keybdev not found   
* inserted /tmp/scsi_mod.o   
* inserted /tmp/usb_storage.o   
* load module set done   
(...)   
   
This is rather strange.    
   
Anyway. The installation works OK (installs, boots, works   
after boot) with both USB devices (keyboard, mouse).    
   
Comment 7 Matt Wilson 2002-12-14 19:53:24 EST
works for me - reopen if you can still reproduce.
Comment 8 Jos Vos 2002-12-15 08:24:25 EST
IIRC, it still happened with the first 8.1 beta.  Unfortunately, I have not
always such a specific (i8xx) system available for test purposes, so I can't
reproduce it now.  Will probably be able to try again in one or two weeks.

Note You need to log in before you can comment on or make changes to this bug.