Bug 595674 - acl should depend on the same version of libacl
Summary: acl should depend on the same version of libacl
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: acl   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Kamil Dudka
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 593740
TreeView+ depends on / blocked
 
Reported: 2010-05-25 11:15 UTC by Kamil Dudka
Modified: 2010-12-06 20:07 UTC (History)
4 users (show)

Fixed In Version: acl-2.2.49-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 660453 (view as bug list)
Environment:
Last Closed: 2010-07-02 18:47:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kamil Dudka 2010-05-25 11:15:31 UTC
Description of problem:
The dependency is missing.

Version-Release number of selected component (if applicable):
acl-2.2.49-3.el6

Additional info:
The same problem in rawhide.

Comment 1 RHEL Product and Program Management 2010-05-25 11:36:25 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Kamil Dudka 2010-05-25 11:56:19 UTC
fixed in rawhide and built as acl-2.2.49-7.fc14

Comment 3 Kamil Dudka 2010-05-25 15:09:36 UTC
how to check:

$ rpm -q acl --requires | grep libacl' '

Comment 4 Kamil Dudka 2010-05-25 17:09:59 UTC
built as acl-2.2.49-4.el6

Comment 6 Miroslav Vadkerti 2010-06-04 12:50:17 UTC
VERIFIED as fixed in acl-2.2.49-4.el6 in compose RHEL6.0-Snapshot-6:

[root@pogolinux-2 ~]# rpm -q acl
acl-2.2.49-4.el6.i686
[root@pogolinux-2 ~]# rpm -q acl --requires | grep libacl' '
libacl = 2.2.49-4.el6

Comment 7 releng-rhel@redhat.com 2010-07-02 18:47:53 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Comment 8 Fedora Update System 2010-08-07 23:25:51 UTC
acl-2.2.49-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Andreas Gruenbacher 2010-12-05 21:24:00 UTC
Sorry to bring this up after the fact, but what is the reason for this change?  The acl package already depends on the libacl package through the automatically generated shared library dependencies, which are (on a RHEL6 x86_64 system):

    libacl.so.1()(64bit)
    libacl.so.1(ACL_1.0)(64bit)

I don't think there is a need to tie the acl and libacl packages together more firmly than that.

Comment 12 Kamil Dudka 2010-12-06 08:21:25 UTC
Andreas, the change has been recommended by our sanity checking tool for RHEL-6.  Would there be any considerable benefit if we leaved the dependency more untied?

Comment 13 Andreas Gruenbacher 2010-12-06 08:48:13 UTC
I don't know, what is it that you are trying to achieve?  Somebody must have implemented this check for a reason.

In this particular case, the acl package also depends on the libattr shared library and package via libacl.  There is no explicit package dependency from either acl or libacl to libattr.  So again, what's the goal?

If you want all package dependencies to be explicit, then an easier way to achieve that would be to change rpm's find-requires script to generate those dependencies instead of generating shared library dependencies.  (Doing this sounds weird to me, though.)

Comment 14 Kamil Dudka 2010-12-06 13:10:22 UTC
Right, but libacl is a sub-package of acl, libattr is not.  We prefer sub-packages to be at the same version as the master package unless there is some reason to allow divergence.

E.g. the update system in Fedora suggests to update the acl package, even if the fix went actually to libacl.  Then if user really updates acl, he will most likely claim the bug is not fixed.  The added dependency forces also update of libacl in that case.  A similar confusion may happen on RHEL, if the user does not install all recommended updates for some reason.

Comment 15 Andreas Gruenbacher 2010-12-06 19:42:12 UTC
Okay, that explains the idea is behind those dependencies, thanks for the explanation.

In that case it would make sense, IMHO, to encode this policy into rpm's find-requires script.  It can't be that hard to generate explicit package dependencies between binary packages built from the same spec file if there are shared library dependencies; rpm already figures out the shared library dependencies, anyway.

Comment 16 Kamil Dudka 2010-12-06 20:00:42 UTC
Sounds like a good idea.  I am only not sure how many packages would need to allow the divergence.  I'll clone the bug for rpm, in order to get it properly evaluated by rpm hackers.


Note You need to log in before you can comment on or make changes to this bug.