Bug 595892 - totem doesn't check for codec on subsequent plays
Summary: totem doesn't check for codec on subsequent plays
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: totem
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Bastien Nocera
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 598580
TreeView+ depends on / blocked
 
Reported: 2010-05-25 20:56 UTC by Máirín Duffy
Modified: 2017-12-06 11:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 598580 (view as bug list)
Environment:
Last Closed: 2017-12-06 11:39:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Máirín Duffy 2010-05-25 20:56:03 UTC
Description of problem:

Say I have a fresh RHEL system, and I have an mpg I'm trying to play.
Totem gives me a popup (I think through packagekit) that it can search for the appropriate codec. So I told it, okay, go search, and it didn't find it. 

Keeping totem open, I set up rpm fusion and installed the gstreamer-*-plugins via yum in a terminal. I went back to the totem window and hit play. It gave me a message saying it couldn't play the movie, it was missing codecs.

I closed totem. I re-opened it. The movie played fine.

I think maybe totem should check again when I hit play after doing the manual codec install? It seemed to be assuming it didn't have the codec and not re-checking.

Maybe it's a silly issue, but when I was in the thick of it, it confused me a lot until I figured out what was going on and thought to restart totem. I figured it would be worth a bug report, just in case.

Version-Release number of selected component (if applicable):
totem-2.28.5-6.el6.x86_64
gstreamer-0.10.28-2.fc13.x86_64 <= yeah I know, this is because of another bug with ogv playback that I talked to Bastien about, maybe it's part of the problem here)
PackageKit-0.5.8-6.el6.x86_64

How reproducible:
it's a little hard to reproduce because you can't have the codecs already installed to reproduce it.

Comment 2 Bastien Nocera 2010-05-25 22:45:51 UTC
That's not a bug, it's working as designed.

We didn't want to have the codec installer show up for every file of the same type you tried to play. So we try to auto-install the codecs once for each time Totem was run.

If PackageKit could make sure that the user only gets asked once for every run, *unless something changed* (like a new repository being setup), then we could disable that.

Comment 3 Richard Hughes 2010-06-01 15:25:56 UTC
I think adding this functionality to PK in el6 has the potential to break other stuff or cause general user interface suckage. I do think we could add such a feature in F14 tho, and *maybe* backport to el6 when things have been debugged and the user experience checked.

From an implementation point of view, we can keep a list of the results from the WhatProvides method and drop the cache if we get RepoListChanged from packagekitd.

Mo, could you clone this bug for f14 and assign it to gnome-packagekit please. Thanks.

Comment 4 Máirín Duffy 2010-06-01 16:37:09 UTC
Hi Richard, sure thing:
https://bugzilla.redhat.com/show_bug.cgi?id=598580

Comment 5 RHEL Program Management 2010-06-07 16:13:31 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Matthias Clasen 2010-06-14 16:11:07 UTC
Based on comment 3, this should not be targeted for 6.0

Comment 8 RHEL Program Management 2010-07-15 14:57:03 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 9 Jan Kurik 2017-12-06 11:39:12 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.