Bug 595950 - System lockup after seeing oops in iwl_bg_request_scan()
Summary: System lockup after seeing oops in iwl_bg_request_scan()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 00:52 UTC by Tony Breeds
Modified: 2010-07-18 16:37 UTC (History)
7 users (show)

Fixed In Version: kernel-2.6.32.13-124.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-18 16:37:09 UTC
Type: ---


Attachments (Terms of Use)
Ooops from ABRT (2.27 KB, application/octet-stream)
2010-05-26 00:52 UTC, Tony Breeds
no flags Details

Description Tony Breeds 2010-05-26 00:52:05 UTC
Created attachment 416591 [details]
Ooops from ABRT

Description of problem:
After upgrading from kernel-2.6.32.11-99.fc12.i686 to 2.6.32.12-115.fc12.i686 My system will lockup when the associated with an AP.  This happens regardless of how active the link/laptop is

Version-Release number of selected component (if applicable):
2.6.32.12-115.fc12.i686 

How reproducible:

100% on my system takes about 90mins

Steps to Reproduce:
1. Associate with AP
2. wait

Additional info:
The system profile is at:
   http://www.smolts.org/client/show/pub_2a2da6a7-23ca-46df-be95-283a39a1c857
There are 3 similar bugs:
   https://bugzilla.redhat.com/buglist.cgi?quicksearch=iwl_bg_request_scan
but 1 of those is Fedora-13 and the other 2 are RHEL-6

Comment 1 Stanislaw Gruszka 2010-06-05 22:20:42 UTC
Try up-to-date kernel like this one:
http://koji.fedoraproject.org/koji/buildinfo?buildID=175410
It have patch applied that fix similar F-13 bug.

Comment 2 Tony Breeds 2010-06-07 04:03:47 UTC
(In reply to comment #1)
> Try up-to-date kernel like this one:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=175410
> It have patch applied that fix similar F-13 bug.    

This seems to have worked.  Wireless has been okay for 3 hours since I installed and rebooted.  Before I say for sure that it's solved, I'd like to test this at home.

Comment 4 Tony Breeds 2010-06-07 23:21:25 UTC
last night I left my machine connected via wireless and there was no lockup.

I'd say the patch is good!


Note You need to log in before you can comment on or make changes to this bug.