Bug 59602 - Menu is too big
Menu is too big
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 21:36 EST by Mike Chambers
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 08:28:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of KDE menu showing extra space (45.25 KB, image/jpeg)
2002-03-21 08:28 EST, Jay Turner
no flags Details

  None (edit)
Description Mike Chambers 2002-02-10 21:36:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When clicking on the Big K button, the menu that initially comes up is too 
large even though the names are small.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Login to KDE
2.Press the Big K button
3.Look at the menu
	

Actual Results:  The menu is way too big even though the words are small.  This 
happens on an existing user or new user with no kde profile.

Expected Results:  Menu should be smaller, maybe the size of the biggest word 
or preset to a certain width but a lot smaller.

Additional info:

This was from an upgrade of 7.2 with updates to 7.2.90.  Only root had logged 
into KDE once.  No other user had ever logged into kde after the 7.2 install.
Comment 1 Jay Turner 2002-03-19 14:47:57 EST
I'm still seeing this with the latest trees (re0318.1)  Anything we can do about
this?
Comment 2 Bernhard Rosenkraenzer 2002-03-21 05:06:10 EST
I've talked with the base maintainer and he says it's intentional to look more like the 
Windoze start menu, providing users with a look they're expecting. 
Why do you think this is a problem? 
Comment 3 Mike Chambers 2002-03-21 06:52:23 EST
What we mean, is that in windows the menu is as long as the longest word(s).  
What we are seeing in KDE is that the menu is big, way past the longest word
(s).  In other words, it seems to be a lot bigger and take up more space then 
it needs to.  It doesnt' seem to be adjusting to the menu word sizes.

I may have not worded that correctly and maybe Jay can elaborate more or I can 
try to get a screen shot done so you can see what we are seeing in case you are 
not.

I haven't installed beta 3 yet, so not sure if this is the case with that one.
Comment 4 Mike Chambers 2002-03-21 06:53:47 EST
Didn't see Jay get this so resubmitting a change so he can help and get cc'd.
Comment 5 Jay Turner 2002-03-21 08:28:08 EST
Created attachment 49384 [details]
Screenshot of KDE menu showing extra space
Comment 6 Ben Levenson 2002-03-21 11:39:37 EST
I'm guessing, but maybe part of the problem is the new setting under panel
preferences:
   Look and Feel
         |_ Panel
               |_ Menus  :  Prefer description over app name
                                        or
                            Detailed menu entries.

After unchecking these boxes, the menu width sized down noticeably. Now, the 
only difference between my kde-3 box and kde-2.2 install is the addition of the
fancy banner on the left side. Changing to NOTABUG. Reopen if you disagree. :)

Note You need to log in before you can comment on or make changes to this bug.