Bug 596056 - pa_stream_writable_size() failed: Connection terminated
pa_stream_writable_size() failed: Connection terminated
Status: CLOSED DUPLICATE of bug 595948
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pulseaudio (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Lennart Poettering
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 04:52 EDT by Lubos Kocman
Modified: 2010-05-26 16:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 16:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Kocman 2010-05-26 04:52:54 EDT
Description of problem:

Continuous music or video playback (totem or rhythmbox) is being cancelled with error window containing following message:

pa_stream_writable_size() failed: Connection terminated

It happened to me on i386 with RHEL 6 during mp4 (video) playback by using fluendo-codec pack. I first contacted Fluendo group, and their answer after a short investigation was, that the issue is most probably in pulse audio.

!!! The same issue was reported on the machine during playback of mp3 without fluendo codec pack.


Version-Release number of selected component (if applicable):

gstreamer-plugins-good-0.10.18-1.el6.x86_64
gstreamer-0.10.26-2.el6.x86_64
phonon-backend-gstreamer-4.6.2-15.el6.x86_64
gstreamer-python-0.10.16-1.1.el6.x86_64
PackageKit-gstreamer-plugin-0.5.8-6.el6.x86_64
gstreamer-plugins-base-0.10.26-2.el6.x86_64
gstreamer-tools-0.10.26-2.el6.x86_64
gstreamer-plugins-bad-free-0.10.17-4.el6.x86_64
pulseaudio-libs-glib2-0.9.21-8.el6.x86_64
pulseaudio-module-gconf-0.9.21-8.el6.x86_64
pulseaudio-libs-0.9.21-8.el6.x86_64
pulseaudio-0.9.21-8.el6.x86_64
pulseaudio-gdm-hooks-0.9.21-8.el6.x86_64
alsa-plugins-pulseaudio-1.0.21-3.el6.x86_64
pulseaudio-utils-0.9.21-8.el6.x86_64
pulseaudio-module-bluetooth-0.9.21-8.el6.x86_64
pulseaudio-module-x11-0.9.21-8.el6.x86_64
kernel-2.6.32-25.el6.x86_64
dracut-kernel-004-19.el6.noarch
kernel-2.6.32-28.el6.x86_64
kernel-2.6.32-27.el6.x86_64
kernel-firmware-2.6.32-28.el6.noarch
kernel-headers-2.6.32-28.el6.x86_64
totem-2.28.5-6.el6.x86_64
totem-nautilus-2.28.5-6.el6.x86_64
totem-mozplugin-2.28.5-6.el6.x86_64
totem-pl-parser-2.28.2-3.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Watch longer playback of mp4 file on RHEL 6 (totem)

or

1. Listen to multiple mp3 in rhythmbox or totem
  
Actual results:

Cancelled playback with mentioned message

Expected results:

Continuous playback

Additional info:

Error occured after 20 minutes of mp4 playback (on i386)
Error occured after listening multiple mp3 files on (x86_64)
Comment 2 Bill Nottingham 2010-05-26 16:52:36 EDT

*** This bug has been marked as a duplicate of bug 595948 ***

Note You need to log in before you can comment on or make changes to this bug.