Bug 596070 - OS is not set accurately when exporting to RHEV
Summary: OS is not set accurately when exporting to RHEV
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
(Show other bugs)
Version: 5.6
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 09:19 UTC by Matthew Booth
Modified: 2010-11-09 13:22 UTC (History)
6 users (show)

Fixed In Version: virt-v2v-0.6.1-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 19:47:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log during conversion from LIBGUESTFS_TRACE=1 (2.32 KB, text/plain)
2010-06-10 05:10 UTC, Rita Wu
no flags Details
Screen Shot (126.91 KB, image/png)
2010-07-16 06:14 UTC, Rita Wu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0566 normal SHIPPED_LIVE virt-v2v bug fix update 2010-07-27 19:47:38 UTC

Description Matthew Booth 2010-05-26 09:19:28 UTC
Description of problem:
When exporting to RHEV, in the output OVF /ovf:Envelop/Content/Section[@xsi:type='ovf:OperatingSystemSection_Type']/Description is always set to 'Unassigned'. This can apparently cause issues for Windows guests: clock will not be handled correctly and the RHEV agent CD will not be correctly presented to the guest.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-1.el5

Comment 1 Matthew Booth 2010-06-08 15:21:15 UTC
Fix posted: https://www.redhat.com/archives/libguestfs/2010-June/msg00064.html

Comment 2 Matthew Booth 2010-06-08 15:53:30 UTC
The most effective end-to-end test for this is to export a guest to RHEV. After import to RHEV, select the guest under the 'Virtual Machines' tab and look at its meta information in the 'General' tab underneath the guest list. The 'Operating System' field should be correct.

Comment 3 Matthew Booth 2010-06-08 17:34:20 UTC
Fixed in 0.6.0-4.el5

Comment 4 Rita Wu 2010-06-10 05:10:26 UTC
Created attachment 422779 [details]
log during conversion from LIBGUESTFS_TRACE=1

Comment 6 Matthew Booth 2010-06-10 08:59:18 UTC
Unfortunately there's a bug in the error message here which is concealing the interesting information. At some point could you please edit line 862 of /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Target/RHEV.pm, changing '_user_message' to 'user_message', then rerun this test. It should give you a warning message:

Unknown Windows version: X.Y

Can you please post that message to this bug.

Comment 7 Matthew Booth 2010-06-18 12:14:42 UTC
This was caused by a simple typo. The fix is upstream.

Comment 8 Rita Wu 2010-06-25 11:06:42 UTC
(In reply to comment #7)
> This was caused by a simple typo. The fix is upstream.    

Hi Matt,
Which version of virt-v2v supports to convert Windows?

Comment 9 Matthew Booth 2010-06-28 12:53:13 UTC
There's no RHEL 5 build with this fix in it. The fix is in RHEL 6, though.

Comment 10 Rita Wu 2010-07-16 06:14:25 UTC
Created attachment 432308 [details]
Screen Shot

Verified on virt-v2v-0.6.1-1.el5.
Now the 'Operating System' field is correcto for all guests, including RHEL and Windows after exporting to RHEV.

Comment 12 errata-xmlrpc 2010-07-27 19:47:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0566.html


Note You need to log in before you can comment on or make changes to this bug.