Bug 59608 - Installing/booting kernel 2.4.9-21 causes depmod Bad symbol errors
Installing/booting kernel 2.4.9-21 causes depmod Bad symbol errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 23:17 EST by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-13 17:27:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Messages file excerpt of 2.4.9-21 boot...see depmod errors (16.79 KB, text/plain)
2002-02-10 23:21 EST, Need Real Name
no flags Details
output of suggested commands (629 bytes, text/plain)
2002-02-11 12:06 EST, Need Real Name
no flags Details
messages excerpt for latest dialer failure. note KERNEL BUG! (20.23 KB, text/plain)
2002-02-11 15:40 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-02-10 23:17:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Installation of kernel-2.4.9-21 seemed to work wirh up2date-2.7 but depmod
errors were generated.  Further, booting 2.4.9-21 resulted in the same errors. 
Now, modem driver will not work and I can't get online using 2.4.9-21.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Download and install kernel-2.4.9-21 using up2date-2.7
2. reboot
3. try to use dialer
4. Go back to 2.4.2-2 and wish you had bought a mac.
	

Actual Results:  depmod errors are generated on the install and on the boot. 
Modem is useless.

Expected Results:  NO errors should have been generted and modem should work as
before.

Additional info:

I have a file of message excerpts showing the errors generated at boot that I
will attach assuming that is possible on the next page.
Comment 1 Need Real Name 2002-02-10 23:21:01 EST
Created attachment 45184 [details]
Messages file excerpt of 2.4.9-21 boot...see depmod errors
Comment 2 Arjan van de Ven 2002-02-11 10:48:13 EST
This looks Not Good(tm)
Can you reproduce this if you remove the 2.4.9 kernel (rpm -e kernel-2.4.9-21)
and then up2date again ?
And what does

rpm -qa | grep kernel

say ?
Comment 3 Need Real Name 2002-02-11 12:06:02 EST
Created attachment 45259 [details]
output of suggested commands
Comment 4 Need Real Name 2002-02-11 12:06:40 EST
Arjan,
First, I want to update you on how I was able to download the kernel file.  In
my last message i said it was impossible.  On my third reinstall of the OS I
used the mem=nopentium option.  2.4.2-2 still locks but is now far more stable. 
On to the current issue:
I removed the package and tried to run up2date.  It resulted in the excerpt
attached as arjan1.

I have since rebooted and will try to run up2date and reproduce everything. 
I'll keep you up to date (no pun intended).

Ayhan

Comment 5 Arjan van de Ven 2002-02-11 12:09:39 EST
Hmmm are you using non-standard modules/drivers ?
The rpm -e ought to just clean out everything.....
Comment 6 Need Real Name 2002-02-11 15:38:29 EST
I have no knowledge of anything non-standard.  Everything either came off my CDs
or from up2date download.
OK - so I was eventually able to once agin download kernel-2.4.9-21.i686.rpm. 
It installed clean.  It booted clean.  When I tried to use the dialer it
failed.  I tried it twice and have captured the messages produced which are
attached as file mess249.1.  Looks like you guys put some kind of trap in
because the point of error is very obvious at 12:39:20!  Hope this helps.
In addition, when I went back to 2.4.2-2 to try and get online, no matter what I
did I could not get the dialer to work.  This is unusual.  I was about to reload
the OS AGAIN when I remembered I had made a boot floppy.  So I am now running
2.4.2-2 off the boot floppy.
Talk about frustrating!
Appreciate your attention.

Ayhan
Comment 7 Need Real Name 2002-02-11 15:40:10 EST
Created attachment 45319 [details]
messages excerpt for latest dialer failure.  note KERNEL BUG!
Comment 8 Need Real Name 2002-02-13 16:23:19 EST
Guys,
Haven't heard from you guys for awhile.  Have you had a chance to look at the
kernel bug in mess249.1?  I'm still running on 2.4.2-2 off the hard drive. 
Lockups still occurring but I am encouraged by your recent help.
Ayhan
Comment 9 Arjan van de Ven 2002-02-13 16:27:26 EST
You could have mentioned that you are using a binary only kernel module...
That kernel module is VERY much the fault here, the kernel just notices that it
does something very bad and aborts.....
Comment 10 Need Real Name 2002-02-13 16:47:59 EST
Well it was nice of you to wait a few days before enlightening me!

SO the dialer is flaky.  That isn't news.  That's been the more minor of my two
main problems since December 13th.  Let that sink in for a second.  What day is
today?  Since December 13th I have been going around in circles, first with
support and now, seemingly, with you.  

I will rephrase my original question once again in the fading hopes of getting
some resolution:
Why does my system habitually lock up?  Forget about the dialer for now.  The
sm56 driver can be addressed later.  Why does my machine lock up?  I had sent an
excerpt to support about a month ago where the messages file said "Unable to
handle kernel paging request" and then "Oops".  I assumed you had seen that or
doesn't Bugzilla share info with support?  If not then its my fault for not
sending you that file.  Would it be worth it for me to send it?

Man, I am at the end of my rope.  I really thought we were making progress.  I
will humble myself one last time and ask for your help.

AM
Comment 11 Need Real Name 2002-02-13 16:48:06 EST
Well it was nice of you to wait a few days before enlightening me!

SO the dialer is flaky.  That isn't news.  That's been the more minor of my two
main problems since December 13th.  Let that sink in for a second.  What day is
today?  Since December 13th I have been going around in circles, first with
support and now, seemingly, with you.  

I will rephrase my original question once again in the fading hopes of getting
some resolution:
Why does my system habitually lock up?  Forget about the dialer for now.  The
sm56 driver can be addressed later.  Why does my machine lock up?  I had sent an
excerpt to support about a month ago where the messages file said "Unable to
handle kernel paging request" and then "Oops".  I assumed you had seen that or
doesn't Bugzilla share info with support?  If not then its my fault for not
sending you that file.  Would it be worth it for me to send it?

Man, I am at the end of my rope.  I really thought we were making progress.  I
will humble myself one last time and ask for your help.

AM
Comment 12 Arjan van de Ven 2002-02-13 16:54:26 EST
If you had informed us from the beginning that you were using binary only
modules from the start this would have been a lot simpler to handle.
Comment 13 Need Real Name 2002-02-13 17:00:53 EST
Arjan,
I don't even know what that means!  I assume you mean the sm56 rpm.  The
original came off the RedHat CD and i have since found another version on a
mtorola website.  They are loaded and installed just like any other rpm.  I
don't see the distinction or why they are "binary only"

Sorry man but I get frustrated.

If 2.4.9-21 is in fact the fix for my lockup problem, then i'll just have to
accept that and try to find an appropriate modem/driver that works with it.  Is
that the bottom line?

AM
Comment 14 Michael K. Johnson 2002-02-13 17:11:30 EST
$ locate sm56
/opt/office52/program/libsm569li.so
/opt/office52/program/resource/sm56901.res

We don't ship a sm56 module in the kernel package.  Can you be
more specific about where you got the sm56 module?  Was it one
of the third-party application discs?  (If so, those packages
are supported solely by their vendors.)
Comment 15 Need Real Name 2002-02-13 17:22:40 EST
OK I understand.  You are exactly correct.  The sm56 driver in question
originally came off the RH7.1 Linux Applications CD Workstation Edition.

Let me summarize to be clear:
1) 2.4.9-21 fixes the lockup problem (I haven't used it long enough to be sure.)
2) The sm 56 driver is a separate issue that you do not support.

If this is true, then I won't bug you guys any more.  Thanks for your help and
patience and if I offended Arjan please tell him I apologize.

AM
Comment 16 Arjan van de Ven 2002-02-13 17:27:22 EST
I'm am not offended; it is just that if I had known the sm56 situation from the
start I would have been able to diagnose/help much more effectively ;(
Comment 17 Michael K. Johnson 2002-02-13 17:30:20 EST
You are precisely correct in your summary.

The sm56 driver is supported (or not supported, as the case
may be) by Motorola itself.  I don't have more direct info
from Motorola on their level of support for it.

No offense.  :-)

I'll close this as ERRATA; you can re-open if the lockup occurs
again with the 2.4.9-21 kernel without the sm56 driver.

Note You need to log in before you can comment on or make changes to this bug.