Bug 596091 - Virt-V2V fails with an error converting a windows guest if there is no config file
Virt-V2V fails with an error converting a windows guest if there is no config...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 05:57 EDT by Matthew Booth
Modified: 2010-06-22 08:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.6.0-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 08:49:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2010-05-26 05:57:40 EDT
Description of problem:
=====
./v2v/run-v2v-locally -ic qemu+ssh://root@blue.rhev.marston/system -o rhev -osd blue:/export/export winxp-minimal
root@blue.rhev.marston's password: 
root@blue.rhev.marston's password: 
mount_ro: /dev/sda on /temp/transferZXQLtK: mount: you must specify the filesystem type at /home/mbooth/src/virt-v2v/blib/lib/Sys/VirtV2V/Converter/Windows.pm line 189.
virt-v2v: Failed to unmount blue:/export/export. Command exited with status 16. Output was: umount.nfs: /tmp/EfF2OGpxfX: device is busy
umount.nfs: /tmp/EfF2OGpxfX: device is busy

virt-v2v: Failed to remove mount directory /tmp/EfF2OGpxfX: Device or resource busy
=====

The same issue was fixed for Linux guests in f4823727dd67f59e405162714210bfe9feef4970.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-1.el5
Comment 1 Matthew Booth 2010-05-26 08:18:33 EDT
Fix posted: https://www.redhat.com/archives/libguestfs/2010-May/msg00148.html
Comment 2 Matthew Booth 2010-06-07 08:39:18 EDT
Fixed in 0.6.0-3.el5
Comment 3 Rita Wu 2010-06-08 02:54:02 EDT
Hi Matt,

What is the expected result? The output I got is about Parse.pm, not the transfer or Config.pm you mentioned in comment 1.

Here are my steps:
1. Uncomment Windows app in virt-v2v.conf
2. run v2v:
# virt-v2v -i libvirtxml -o rhev -osd 10.66.70.xx:/v2v/fcp_export win2k8-32.xml
virt-v2v: Unable to parse config file /etc/virt-v2v.conf: 
not well-formed (invalid token) at line 161, column 6, byte 6067 at
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/XML/Parser.pm
line 187
Comment 4 Matthew Booth 2010-06-08 04:37:39 EDT
You only hit this bug when there was no config file at all. Since 0.6.0, virt-v2v now uses /etc/virt-v2v.conf by default if no config file is specified, so to hit this bug you'd need to remove that file and not specify a replacement.

Incidentally, it sounds like you introduced a typo in your config file. That error is from the XML parser. You'd only get that if it wasn't valid XML.
Comment 5 Rita Wu 2010-06-08 06:40:18 EDT
Verified on virt-v2v-0.6.0-3.el5 + v2v-libvirt-0.8.1-1.el5
Now it will point "No config specified" when there is no config file.

Steps:

1. Rename virt-v2v.conf
# ll /etc/virt-v2v.conf.
virt-v2v.conf.bak      virt-v2v.conf.rpmsave 

2. Run v2v
============For Windows guest==============
# virt-v2v -i libvirtxml -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export /tmp/win2008-32.raw.xml
 virt-v2v: No config specified. No app match for os='windows' name='viostor'
 major='6' minor='0' arch='i386'
 virt-v2v: Failed to unmount 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export. Command exited with status 1. Output was: umount: /tmp/ZoqnQv8Gy0: device is busy
 umount: /tmp/ZoqnQv8Gy0: device is busy

 virt-v2v: Failed to remove mount directory /tmp/ZoqnQv8Gy0: Device or
 resource busy

      
========For Linux guest=============
 # virt-v2v  -i libvirtxml -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export xen-rhel55-64-pv-raw.xml
virt-v2v: No config specified. No capability match for os='linux' name='virtio' distro='rhel' major='5' minor='5'
virt-v2v: WARNING: No mapping found for bridge interface xenbr0 in config file. The converted guest may not start until its network interface is updated.
virt-v2v: rhel55-64 configured without virtio drivers
Comment 8 errata-xmlrpc 2010-06-22 08:49:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2010-0495.html

Note You need to log in before you can comment on or make changes to this bug.