Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 596093 - 16bit integer qdev properties are not parsed correctly.
16bit integer qdev properties are not parsed correctly.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 06:00 EDT by Gerd Hoffmann
Modified: 2013-01-09 17:37 EST (History)
5 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.71.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 10:54:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerd Hoffmann 2010-05-26 06:00:59 EDT
Description of problem:

$ qemu-system-x86_64  -device 
virtio-blk-pci,logical_block_size=4096,physical_block_size=4096,drive=boot
-drive file=/tmp/a.qcow2,if=none,id=boot

gives me: Floating point exception

The crash is in hw/virtio-blk.c:505 blkcfg.blk_size is zero because
s->conf->logical_block_size is zero.
Comment 1 Gerd Hoffmann 2010-05-26 06:03:59 EDT
Analyzed by armbru: setting physical_block_size overwrites logical_block_size due to incorrect use of inttypes macros in parse_uint16().
Comment 3 RHEL Product and Program Management 2010-05-26 14:46:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Mike Cao 2010-06-08 01:50:56 EDT
Reproduced in qemu-kvm-0.12.1.2-2.69.el6

Verified in qemu-kvm-0.12.1.2-2.71.el6

Steps:
1.start VM with following command.
#/usr/libexec/qemu-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name tt -uuid `uuidgen` -rtc-td-hack -boot c -drive file=/home/RHEL-Server-6.0-64-virtio.raw,if=none,id=drive-virtio0-0-0,boot=on,format=raw -device virtio-blk-pci,drive=drive-virtio0-0-0,id=ide0-0-0,logical_block_size=4096,physical_block_size=4096 -net nic,macaddr=20:40:50:12:23:21,model=virtio,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -vnc :8 -monitor stdio

Actual Results:
qemu-kvm will not crash for Floating point exception,Guest can work successfully.

The bug has already been fixed.
Comment 9 lihuang 2010-07-12 10:54:10 EDT
according to #c7. closing

Note You need to log in before you can comment on or make changes to this bug.