Bug 59622 - Printconf needs better support for nonstandard options/drivers.
Printconf needs better support for nonstandard options/drivers.
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-11 08:56 EST by Joe Krahn
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:37:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Krahn 2002-02-11 08:56:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
Often it is ueful to pass extra options to gs, like the old redhat print system.
This can be used, for example, with hpijs to pass the duplexing option
"-dDuplex=n". This might also work in the case of bug 58232, if one knows the
right string to send.

Similarly, I have a Lexmark Z33 printer which works, but only with closed-source
driver from Lexmark. It would be nice to have a generic non-postscript printer
entry that allows you to enter the full postscript-to-printer-data command line.
Then unsupported printers could be added in a way that fits in to the printconf
system, and it will show up in the list of printers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to add an unsupported gs option.
2.
3.
	

Additional info:

You're doing a good job of supporting many printers and options, but there will
always be new printers or special cases where advanced customizations are
useful.
Comment 1 Tim Waugh 2002-02-12 09:12:53 EST
Yes, it would be nice to add this.  This is a different thing than -Z options,
isn't it?
Comment 2 Joe Krahn 2002-02-13 13:25:48 EST
-Z options is a way to pass information to the filters. It should be used to
override any of the ioptions available in the printconf-gui driver config. It
could be used to pass random GS options as well, if one of the options were
extra gs arguments. But, you wouldn't want to have to pass that option every
time you print, so a gs-options box in printconf-gui is needed. The only hard
part may be that printconf-gui is set up now for all multiple choice, no text
entry boxes.

Right now, it looks like printconf/foomatic completely ignore -Z options. They
get converted to the environment variable ZOPT by /usr/bin/magicfilter-t, but
the string ZOPT does not occur in any other foomatic or printconf file. The
current standard for -Z is to specifiy just -ZLetter, not -ZPageSize=Letter. So,
implementing -Z will mean scanning the *.foo file for option matches, then
overriding mf.cfg.

Specifiy a complete generic postscript-to-printer command line also wouldn't be
too hard if printconf-gui can support a generic text-entry box. You just
override the standard 'cmd' value, instead of just modifying it in the case of
extra gs options.
Comment 3 Tim Waugh 2002-02-15 06:23:55 EST
Regarding -Z, see bug #59890.
Comment 4 Joe Krahn 2002-02-15 09:13:12 EST
Bugzilla won't let me see bug #59890.  It says I don't have permission.
Comment 5 Tim Waugh 2002-02-15 09:19:53 EST
Sorry, I meant bug #58980.
Comment 6 adrian.lawrence 2002-02-17 08:12:16 EST
I too have found printconf seems more like a Microsoft product :-)
It stops me using my printer properly. In this case a Brother HL-1250
which has custom support in ghostscript. Before I used postscript.cfg
files to pass the extra ghostscript options like

EXTRA_GS_OPTIONS="-dPaperType=3"

Such options determine the paper thickness and toner density. The paper 
thickness is an especially important parameter with these printers.

Some general mechanism to allow arbitrary parameters to be passed to 
Ghostscript is needed at least. Of course more general hooks are needed. 

Being too clever and knowing better than the user is not what one expects from a
linux environment :-(

ael
Comment 7 Tim Waugh 2002-02-22 09:21:46 EST
See <http://www.linuxprinting.org/pipermail/foomatic-devel/2002q1/000682.html>
and follow-ups.  Summary: this is on Till's TODO list.
Comment 8 Bill Nottingham 2006-08-07 13:33:47 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 9 Bill Nottingham 2006-10-18 10:37:35 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.