Bug 59625 - Fix to gnome-libs included db1 build
Summary: Fix to gnome-libs included db1 build
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218 79579
TreeView+ depends on / blocked
 
Reported: 2002-02-11 14:06 UTC by Bernhard Rosenkraenzer
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 01:10:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernhard Rosenkraenzer 2002-02-11 14:06:24 UTC
Description of Problem:
Trying to rebuild the package on a system without gnome-libs-devel fails because
-ldb1 can't be resolved. The fix is to ln -s libdb.a libdb1.a after building db1
and to add -L`pwd`/%{dblib}/PORT/linux to CFLAGS.

Version-Release number of selected component (if applicable):
1.4.1.2.90-9

How Reproducible:
100%

Steps to Reproduce:
1. rpm -e gnome-libs-devel
2. rpm --rebuild gnome-libs-1.4.1.2.90-9.src.rpm

Comment 1 Havoc Pennington 2002-07-02 23:01:34 UTC
This may have been fixed.

Comment 2 Havoc Pennington 2003-01-07 01:10:45 UTC
I'm fairly sure we fixed this at some point.


Note You need to log in before you can comment on or make changes to this bug.