Bug 596368 - Sierra Wireless 881U not properly initializing
Sierra Wireless 881U not properly initializing
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ModemManager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 12:51 EDT by Bob Kozdemba
Modified: 2010-06-29 13:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 13:14:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Kozdemba 2010-05-26 12:51:23 EDT
Description of problem:
Sierra Wireless 881U not properly initializing by modem-manager

Version-Release number of selected component (if applicable):
rhel6 beta (2.6.32-29.el6.x86_64)
modem-manager (ModemManager-0.4.0-0.1.el6.x86_64)

How reproducible:
100%


Steps to Reproduce:
1.Plug in 881U and observe /var/log/messages
2.Similar messages are logged when trying to connect w/Network Manager to AT&T
3.
  
Actual results:
When the 881U is plugged in, the following messages appear in
/var/log/messages

May 26 11:26:33 fugue kernel: usb 6-2: new full speed USB device using uhci_hcd and address 2
May 26 11:26:33 fugue kernel: usb 6-2: New USB device found, idVendor=1199, idProduct=0fff
May 26 11:26:33 fugue kernel: usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 26 11:26:33 fugue kernel: usb 6-2: Product: USB MMC Storage
May 26 11:26:33 fugue kernel: usb 6-2: Manufacturer: Sierra Wireless
May 26 11:26:33 fugue kernel: usb 6-2: SerialNumber: SWOC22905731
May 26 11:26:33 fugue kernel: usb 6-2: configuration #1 chosen from 1 choice
May 26 11:26:34 fugue kernel: Initializing USB Mass Storage driver...
May 26 11:26:34 fugue kernel: usb-storage: probe of 6-2:1.0 failed with error -5
May 26 11:26:34 fugue kernel: usbcore: registered new interface driver usb-storage
May 26 11:26:34 fugue kernel: USB Mass Storage support registered.
May 26 11:26:34 fugue kernel: usb 6-2: USB disconnect, address 2
May 26 11:26:35 fugue kernel: usb 6-2: new full speed USB device using uhci_hcd and address 3
May 26 11:26:35 fugue kernel: usb 6-2: New USB device found, idVendor=1199, idProduct=6856
May 26 11:26:35 fugue kernel: usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
May 26 11:26:35 fugue kernel: usb 6-2: Product: AirCard
May 26 11:26:35 fugue kernel: usb 6-2: Manufacturer: Sierra Wireless, Incorporated
May 26 11:26:35 fugue kernel: usb 6-2: configuration #1 chosen from 1 choice
May 26 11:26:36 fugue kernel: usbcore: registered new interface driver usbserial
May 26 11:26:36 fugue kernel: USB Serial support registered for generic
May 26 11:26:36 fugue kernel: usbcore: registered new interface driver usbserial_generic
May 26 11:26:36 fugue kernel: usbserial: USB Serial Driver core
May 26 11:26:36 fugue kernel: USB Serial support registered for Sierra USB modem
May 26 11:26:36 fugue kernel: sierra 6-2:1.0: Sierra USB modem converter detected
May 26 11:26:36 fugue kernel: usb 6-2: Sierra USB modem converter now attached to ttyUSB0
May 26 11:26:36 fugue kernel: usb 6-2: Sierra USB modem converter now attached to ttyUSB1
May 26 11:26:36 fugue kernel: usb 6-2: Sierra USB modem converter now attached to ttyUSB2
May 26 11:26:36 fugue kernel: usbcore: registered new interface driver sierra
May 26 11:26:36 fugue kernel: sierra: v.1.3.8:USB Driver for Sierra Wireless USB modems
May 26 11:26:36 fugue modem-manager: (ttyUSB0) opening serial device...
May 26 11:26:36 fugue modem-manager: (ttyUSB2) opening serial device...
May 26 11:26:36 fugue modem-manager: (ttyUSB1) opening serial device...
May 26 11:26:39 fugue modem-manager: (ttyUSB2) closing serial device...
May 26 11:26:39 fugue modem-manager: (ttyUSB2) opening serial device...
May 26 11:26:39 fugue modem-manager: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB2
May 26 11:26:40 fugue modem-manager: (ttyUSB2) closing serial device...
May 26 11:26:40 fugue modem-manager: (ttyUSB0) closing serial device...
May 26 11:26:40 fugue modem-manager: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB0
May 26 11:26:50 fugue modem-manager: (ttyUSB1) closing serial device...
May 26 11:26:50 fugue modem-manager: (ttyUSB1) opening serial device...
May 26 11:26:56 fugue modem-manager: (ttyUSB1) closing serial device...
May 26 11:26:56 fugue NetworkManager[1552]: <warn> (ttyUSB2): failed to look up interface index
May 26 11:26:56 fugue NetworkManager[1552]: <info> (ttyUSB2): new GSM device (driver: 'sierra' ifindex: -1)
May 26 11:26:56 fugue NetworkManager[1552]: <info> (ttyUSB2): exported as /org/freedesktop/NetworkManager/Devices/2
May 26 11:26:56 fugue NetworkManager[1552]: <info> (ttyUSB2): now managed
May 26 11:26:56 fugue NetworkManager[1552]: <info> (ttyUSB2): device state change: 1 -> 2 (reason 2)
May 26 11:26:56 fugue NetworkManager[1552]: <info> (ttyUSB2): deactivating device (reason: 2).
May 26 11:26:56 fugue NetworkManager[1552]: <info> (ttyUSB2): device state change: 2 -> 3 (reason 0)

When NetworkManager is asked to connect to AT&T, the following messages are logged:

May 26 11:31:07 fugue NetworkManager[1552]: <info> Activation (ttyUSB2) starting connection 'AT&T Data Connect'
May 26 11:31:07 fugue NetworkManager[1552]: <info> (ttyUSB2): device state change: 3 -> 4 (reason 0)
May 26 11:31:07 fugue NetworkManager[1552]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
May 26 11:31:07 fugue NetworkManager[1552]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
May 26 11:31:07 fugue NetworkManager[1552]: <info> (ttyUSB2): device state change: 4 -> 6 (reason 0)
May 26 11:31:07 fugue NetworkManager[1552]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
May 26 11:31:07 fugue NetworkManager[1552]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
May 26 11:31:07 fugue NetworkManager[1552]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
May 26 11:31:07 fugue NetworkManager[1552]: <info> (ttyUSB2): device state change: 6 -> 4 (reason 0)
May 26 11:31:07 fugue NetworkManager[1552]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
May 26 11:31:07 fugue modem-manager: (ttyUSB2) opening serial device...
May 26 11:31:07 fugue modem-manager: Modem /org/freedesktop/ModemManager/Modems/3: state changed (disabled -> enabling)
May 26 11:31:09 fugue kernel: usb 6-2: USB disconnect, address 9
May 26 11:31:09 fugue modem-manager: (ttyUSB2) closing serial device...
May 26 11:31:09 fugue kernel: sierra ttyUSB0: Sierra USB modem converter now disconnected from ttyUSB0
May 26 11:31:09 fugue kernel: sierra ttyUSB1: Sierra USB modem converter now disconnected from ttyUSB1
May 26 11:31:09 fugue kernel: sierra ttyUSB2: Sierra USB modem converter now disconnected from ttyUSB2
May 26 11:31:09 fugue kernel: sierra 6-2:1.0: device disconnected
May 26 11:31:09 fugue modem-manager: Modem /org/freedesktop/ModemManager/Modems/3: state changed (enabling -> disabled)
May 26 11:31:09 fugue NetworkManager[1552]: <info> (ttyUSB2): now unmanaged
May 26 11:31:09 fugue NetworkManager[1552]: <info> (ttyUSB2): device state change: 4 -> 1 (reason 36)
May 26 11:31:09 fugue NetworkManager[1552]: <info> (ttyUSB2): deactivating device (reason: 36).
May 26 11:31:09 fugue NetworkManager[1552]: <info> (ttyUSB2): cleaning up...
May 26 11:31:09 fugue NetworkManager[1552]: <info> (ttyUSB2): taking down device.
May 26 11:31:14 fugue kernel: usb 6-2: new full speed USB device using uhci_hcd and address 10
May 26 11:31:14 fugue kernel: usb 6-2: New USB device found, idVendor=1199, idProduct=0fff
May 26 11:31:14 fugue kernel: usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 26 11:31:14 fugue kernel: usb 6-2: Product: USB MMC Storage
May 26 11:31:14 fugue kernel: usb 6-2: Manufacturer: Sierra Wireless
May 26 11:31:14 fugue kernel: usb 6-2: SerialNumber: SWOC22905731
May 26 11:31:14 fugue kernel: usb 6-2: configuration #1 chosen from 1 choice
May 26 11:31:14 fugue kernel: usb-storage: probe of 6-2:1.0 failed with error -5
May 26 11:31:15 fugue kernel: usb 6-2: USB disconnect, address 10
May 26 11:31:16 fugue kernel: usb 6-2: new full speed USB device using uhci_hcd and address 11
May 26 11:31:16 fugue kernel: usb 6-2: New USB device found, idVendor=1199, idProduct=6856
May 26 11:31:16 fugue kernel: usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
May 26 11:31:16 fugue kernel: usb 6-2: Product: AirCard
May 26 11:31:16 fugue kernel: usb 6-2: Manufacturer: Sierra Wireless, Incorporated
May 26 11:31:16 fugue kernel: usb 6-2: configuration #1 chosen from 1 choice
May 26 11:31:16 fugue kernel: sierra 6-2:1.0: Sierra USB modem converter detected
May 26 11:31:16 fugue kernel: usb 6-2: Sierra USB modem converter now attached to ttyUSB0
May 26 11:31:16 fugue kernel: usb 6-2: Sierra USB modem converter now attached to ttyUSB1
May 26 11:31:16 fugue kernel: usb 6-2: Sierra USB modem converter now attached to ttyUSB2
May 26 11:31:16 fugue modem-manager: (ttyUSB0) opening serial device...
May 26 11:31:16 fugue modem-manager: (ttyUSB1) opening serial device...
May 26 11:31:16 fugue modem-manager: (ttyUSB2) opening serial device...
May 26 11:31:19 fugue modem-manager: (ttyUSB2) closing serial device...
May 26 11:31:19 fugue modem-manager: (ttyUSB2) opening serial device...
May 26 11:31:19 fugue modem-manager: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB2
May 26 11:31:21 fugue modem-manager: (ttyUSB2) closing serial device...
May 26 11:31:21 fugue modem-manager: (ttyUSB0) closing serial device...
May 26 11:31:21 fugue modem-manager: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB0
May 26 11:31:30 fugue modem-manager: (ttyUSB1) closing serial device...
May 26 11:31:30 fugue modem-manager: (ttyUSB1) opening serial device...
May 26 11:31:36 fugue modem-manager: (ttyUSB1) closing serial device...
May 26 11:31:36 fugue NetworkManager[1552]: <warn> (ttyUSB2): failed to look up interface index
May 26 11:31:36 fugue NetworkManager[1552]: <info> (ttyUSB2): new GSM device (driver: 'sierra' ifindex: -1)
May 26 11:31:36 fugue NetworkManager[1552]: <info> (ttyUSB2): exported as /org/freedesktop/NetworkManager/Devices/6
May 26 11:31:36 fugue NetworkManager[1552]: <info> (ttyUSB2): now managed
May 26 11:31:36 fugue NetworkManager[1552]: <info> (ttyUSB2): device state change: 1 -> 2 (reason 2)
May 26 11:31:36 fugue NetworkManager[1552]: <info> (ttyUSB2): deactivating device (reason: 2).
May 26 11:31:36 fugue NetworkManager[1552]: <info> (ttyUSB2): device state change: 2 -> 3 (reason 0)

Expected results:
Modem should dial AT&T as configured.

Additional info:
Does not work w/F12 either. I did not try F13.
Works fine if I use 'pppd' and chat scripts supplied by Sierra's web site.
Comment 1 Dan Williams 2010-05-26 13:03:26 EDT
Looks like the modem firmware is crashing.  Can you do the following for me as root?

1) service NetworkManager stop
2) killall -TERM modem-manager
3) modem-manager --debug
4) (in another terminal) service NetworkManager start

and then reproduce the problem. Then attach the 'modem-manager --debug' output that was produced.  We'll see if we can find out why the device is crashing.  It may actually take a firmware upgrade to the modem as some older firmwares on these devices (881 pccard, 875, etc) have issues.  Thanks!
Comment 3 Bob Kozdemba 2010-05-26 14:07:45 EDT
[root@fugue ~]# service NetworkManager stop
Stopping NetworkManager daemon:                            [  OK  ]
[root@fugue ~]# killall -TERM modem-manager
[root@fugue ~]# modem-manager --debug
** Message: ModemManager (version 0.4.0-0.1.el6) starting...
** Message: Loaded plugin ZTE
** Message: Loaded plugin Ericsson MBM
** Message: Loaded plugin Huawei
** Message: Loaded plugin Option
** Message: Loaded plugin Longcheer
** Message: Loaded plugin Gobi
** Message: Loaded plugin MotoC
** Message: Loaded plugin SimTech
** Message: Loaded plugin AnyData
** Message: Loaded plugin Option High-Speed
** Message: Loaded plugin Sierra
** Message: Loaded plugin Novatel
** Message: Loaded plugin Nokia
** Message: Loaded plugin Generic
** (modem-manager:3161): DEBUG: (tty/ttyS0): port's parent platform driver is not whitelisted
** (modem-manager:3161): DEBUG: (tty/ttyS1): port's parent platform driver is not whitelisted
** (modem-manager:3161): DEBUG: (tty/ttyS2): port's parent platform driver is not whitelisted
** (modem-manager:3161): DEBUG: (tty/ttyS3): port's parent platform driver is not whitelisted
** (modem-manager:3161): DEBUG: (net/pan0): could not get port's parent device
** (modem-manager:3161): DEBUG: (net/sat0): could not get port's parent device
** (modem-manager:3161): DEBUG: (net/sme0): could not get port's parent device
** Message: (ttyUSB0) opening serial device...
** (modem-manager:3161): DEBUG: <1274897025.812167> (ttyUSB0) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB0): probe requested by plugin 'Sierra'
** Message: (ttyUSB1) opening serial device...
** (modem-manager:3161): DEBUG: <1274897025.817156> (ttyUSB1) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB1): probe requested by plugin 'Sierra'
** Message: (ttyUSB2) opening serial device...
** (modem-manager:3161): DEBUG: <1274897025.822154> (ttyUSB2) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB2): probe requested by plugin 'Sierra'
** (modem-manager:3161): DEBUG: <1274897025.913250> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897026.714604> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897026.716221> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897027.517471> (ttyUSB2): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897028.318653> (ttyUSB2): <-- 'AT+GCAP<CR><CR><LF>+GCAP: +CGSM,+DS,+ES<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897028.318763> (ttyUSB0): --> 'AT+GCAP<CR>'
@                                                                               
"mm-debug.txt" 154L, 12936C                                   1,1           Top
Comment 4 Bob Kozdemba 2010-05-26 14:10:22 EDT
*** This is the complete output, ignore previous post.

[koz@sonata ~]$ cat mm-debug.txt 
[root@fugue ~]# service NetworkManager stop
Stopping NetworkManager daemon:                            [  OK  ]
[root@fugue ~]# killall -TERM modem-manager
[root@fugue ~]# modem-manager --debug
** Message: ModemManager (version 0.4.0-0.1.el6) starting...
** Message: Loaded plugin ZTE
** Message: Loaded plugin Ericsson MBM
** Message: Loaded plugin Huawei
** Message: Loaded plugin Option
** Message: Loaded plugin Longcheer
** Message: Loaded plugin Gobi
** Message: Loaded plugin MotoC
** Message: Loaded plugin SimTech
** Message: Loaded plugin AnyData
** Message: Loaded plugin Option High-Speed
** Message: Loaded plugin Sierra
** Message: Loaded plugin Novatel
** Message: Loaded plugin Nokia
** Message: Loaded plugin Generic
** (modem-manager:3161): DEBUG: (tty/ttyS0): port's parent platform driver is not whitelisted
** (modem-manager:3161): DEBUG: (tty/ttyS1): port's parent platform driver is not whitelisted
** (modem-manager:3161): DEBUG: (tty/ttyS2): port's parent platform driver is not whitelisted
** (modem-manager:3161): DEBUG: (tty/ttyS3): port's parent platform driver is not whitelisted
** (modem-manager:3161): DEBUG: (net/pan0): could not get port's parent device
** (modem-manager:3161): DEBUG: (net/sat0): could not get port's parent device
** (modem-manager:3161): DEBUG: (net/sme0): could not get port's parent device
** Message: (ttyUSB0) opening serial device...
** (modem-manager:3161): DEBUG: <1274897025.812167> (ttyUSB0) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB0): probe requested by plugin 'Sierra'
** Message: (ttyUSB1) opening serial device...
** (modem-manager:3161): DEBUG: <1274897025.817156> (ttyUSB1) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB1): probe requested by plugin 'Sierra'
** Message: (ttyUSB2) opening serial device...
** (modem-manager:3161): DEBUG: <1274897025.822154> (ttyUSB2) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB2): probe requested by plugin 'Sierra'
** (modem-manager:3161): DEBUG: <1274897025.913250> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897026.714604> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897026.716221> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897027.517471> (ttyUSB2): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897028.318653> (ttyUSB2): <-- 'AT+GCAP<CR><CR><LF>+GCAP: +CGSM,+DS,+ES<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897028.318763> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897029.119865> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897029.119918> (ttyUSB2) device open count is 0 (close)
** Message: (ttyUSB2) closing serial device...
** Message: (ttyUSB2) type primary claimed by /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** Message: (ttyUSB2) opening serial device...
** (modem-manager:3161): DEBUG: <1274897029.135169> (ttyUSB2) device open count is 1 (open)
** Message: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB2
** (modem-manager:3161): DEBUG: Added modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: <1274897029.135531> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897029.936685> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897029.936793> (ttyUSB2): --> 'AT+CPIN?<CR>'
** (modem-manager:3161): DEBUG: <1274897029.947269> (ttyUSB2): <-- 'AT+CPIN?<CR>'
** (modem-manager:3161): DEBUG: <1274897029.947360> (ttyUSB0): --> 'ATI<CR>'
** (modem-manager:3161): DEBUG: <1274897030.348051> (ttyUSB0): <-- 'Sierra Wireless, Inc.<LF><CR>MC8781<LF><CR>APP1<LF><CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897030.348144> (ttyUSB2): <-- '<CR><LF>+CPIN: READY<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897030.348294> (ttyUSB2) device open count is 0 (close)
** Message: (ttyUSB2) closing serial device...
** (modem-manager:3161): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** Message: (ttyUSB0) type secondary claimed by /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: <1274897030.358803> (ttyUSB0) device open count is 0 (close)
** Message: (ttyUSB0) closing serial device...
** Message: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB0
** (modem-manager:3161): DEBUG: (tty/ttyUSB1): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: <1274897031.201164> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897035.199811> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897039.199563> (ttyUSB1) device open count is 0 (close)
** Message: (ttyUSB1) closing serial device...
** Message: (ttyUSB1) opening serial device...
** (modem-manager:3161): DEBUG: <1274897039.214123> (ttyUSB1) device open count is 1 (open)
** (modem-manager:3161): DEBUG: <1274897039.214226> (ttyUSB1): --> 00 78 f0 7e
** (modem-manager:3161): DEBUG: <1274897042.203061> (ttyUSB1): --> 00 78 f0 7e
** (modem-manager:3161): DEBUG: <1274897045.202946> (ttyUSB1) device open count is 0 (close)
** Message: (ttyUSB1) closing serial device...
** (modem-manager:3161): DEBUG: (tty/ttyUSB1): ignoring port unsupported by physical modem's plugin
** (modem-manager:3161): DEBUG: Exported modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 as /org/freedesktop/ModemManager/Modems/0
** (modem-manager:3161): DEBUG: (/org/freedesktop/ModemManager/Modems/0): data port is ttyUSB2
** Message: (ttyUSB2) opening serial device...
** (modem-manager:3161): DEBUG: <1274897063.530163> (ttyUSB2) device open count is 1 (open)
** (modem-manager:3161): DEBUG: <1274897063.530207> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
** (modem-manager:3161): DEBUG: <1274897063.631111> (ttyUSB2): --> 'ATZ E0 V1<CR>'
** (modem-manager:3161): DEBUG: <1274897063.642983> (ttyUSB2): <-- 'ATZ E0 V1'
** (modem-manager:3161): DEBUG: <1274897063.643135> (ttyUSB2): <-- '<CR>'
** (modem-manager:3161): DEBUG: <1274897063.664546> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897063.664593> (ttyUSB2): --> 'ATE0<CR>'
** (modem-manager:3161): DEBUG: <1274897063.671409> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897063.671440> (ttyUSB2): --> 'AT+CMEE=1<CR>'
** (modem-manager:3161): DEBUG: <1274897063.684456> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897063.684485> (ttyUSB2): --> 'ATX4 &C1<CR>'
** (modem-manager:3161): DEBUG: <1274897063.695565> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897063.695670> (ttyUSB2): --> 'AT+CFUN=1<CR>'
** (modem-manager:3161): DEBUG: <1274897063.748484> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897065.921796> (ttyUSB2) device open count is 0 (close)
** Message: (ttyUSB2) closing serial device...
** (modem-manager:3161): DEBUG: <1274897065.926101> Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> disabled)
** (modem-manager:3161): DEBUG: Removed modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** Message: (ttyUSB1) opening serial device...
** (modem-manager:3161): DEBUG: <1274897072.814483> (ttyUSB1) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB1): probe requested by plugin 'Sierra'
** Message: (ttyUSB2) opening serial device...
** (modem-manager:3161): DEBUG: <1274897072.819511> (ttyUSB2) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB2): probe requested by plugin 'Sierra'
** Message: (ttyUSB0) opening serial device...
** (modem-manager:3161): DEBUG: <1274897072.826516> (ttyUSB0) device open count is 1 (open)
** (modem-manager:3161): DEBUG: (ttyUSB0): probe requested by plugin 'Sierra'
** (modem-manager:3161): DEBUG: <1274897072.915532> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897073.719562> (ttyUSB2): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897074.520654> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897075.321884> (ttyUSB1): <-- '~\0\31F\0\0\3\0\27\1\0\1\0\0;\-97\-107\-128\31\-57\-1281\-32s\-2!\27c\-30\6\-90\-125\15\-112\0\-119~'
** (modem-manager:3161): DEBUG: <1274897075.321994> (ttyUSB2): <-- 'AT+GCAP<CR><CR><LF>+GCAP: +CGSM,+DS,+ES<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897075.322085> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897075.322228> (ttyUSB2) device open count is 0 (close)
** Message: (ttyUSB2) closing serial device...
** (modem-manager:3161): DEBUG: <1274897075.332623> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897076.133814> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** Message: (ttyUSB2) type primary claimed by /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** Message: (ttyUSB2) opening serial device...
** (modem-manager:3161): DEBUG: <1274897076.138536> (ttyUSB2) device open count is 1 (open)
** Message: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB2
** (modem-manager:3161): DEBUG: Added modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: <1274897076.138912> (ttyUSB2): --> 'AT+CPIN?<CR>'
** (modem-manager:3161): DEBUG: <1274897076.149823> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897076.951157> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897076.951260> (ttyUSB2): <-- 'AT+CPIN?<CR><CR><LF>+CPIN: READY<CR><LF><CR><LF>OK<CR><LF><CR><LF>+PACSP0<CR><LF>'
** (modem-manager:3161): DEBUG: <1274897076.951397> (ttyUSB2) device open count is 0 (close)
** Message: (ttyUSB2) closing serial device...
** (modem-manager:3161): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: <1274897076.961719> (ttyUSB0): --> 'ATI<CR>'
** (modem-manager:3161): DEBUG: <1274897077.362292> (ttyUSB0): <-- 'Sierra Wireless, Inc.<LF><CR>MC8781<LF><CR>APP1<LF><CR><LF>OK<CR><LF>'
** Message: (ttyUSB0) type secondary claimed by /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: <1274897077.363004> (ttyUSB0) device open count is 0 (close)
** Message: (ttyUSB0) closing serial device...
** Message: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB0
** (modem-manager:3161): DEBUG: (tty/ttyUSB1): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:3161): DEBUG: <1274897077.373683> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897079.660773> (ttyUSB1): <-- '~\1\20x\0\3\0\1\16\7\8\0A\0T\0&\0T\2\1e\0\1\0\0\20\0Gq\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\4NETWORK SERVICE CHANGE\0\0\-64\-756\16X\5\-118\16\-8\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\14\16\5\-76\4\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0~'
** (modem-manager:3161): DEBUG: <1274897081.201619> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:3161): DEBUG: <1274897085.199263> (ttyUSB1) device open count is 0 (close)
** Message: (ttyUSB1) closing serial device...
** Message: (ttyUSB1) opening serial device...
** (modem-manager:3161): DEBUG: <1274897085.214511> (ttyUSB1) device open count is 1 (open)
** (modem-manager:3161): DEBUG: <1274897085.214603> (ttyUSB1): --> 00 78 f0 7e
** (modem-manager:3161): DEBUG: <1274897088.203259> (ttyUSB1): --> 00 78 f0 7e
** (modem-manager:3161): DEBUG: <1274897091.203132> (ttyUSB1) device open count is 0 (close)
** Message: (ttyUSB1) closing serial device...
** (modem-manager:3161): DEBUG: (tty/ttyUSB1): ignoring port unsupported by physical modem's plugin
** (modem-manager:3161): DEBUG: Exported modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 as /org/freedesktop/ModemManager/Modems/1
** (modem-manager:3161): DEBUG: (/org/freedesktop/ModemManager/Modems/1): data port is ttyUSB2
    

[koz@sonata ~]$
Comment 5 Bob Kozdemba 2010-05-26 16:44:16 EDT
The AT&T CommMgr (windows app) reports my firmware as version 1.0.0.4 and Sierra'a support website says the current version is 1.2.3.15. I will hold off upgrading in case you want to do more debugging.
Comment 6 RHEL Product and Program Management 2010-05-26 17:26:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Dan Williams 2010-05-26 20:44:50 EDT
I'd actually try the firmware update.  I've had a few 8785 minicard devices (similar to what's in your 881U) and some of them started on the 1.0.x firmware and it wasn't pretty...  these versions have bugs in the firwmare when something tries to talk on multiple ports, which NM does (so you get signal strength while connected) but which wvdial/ppp don't do.

But oddly, the log you've got there indicates that at least by the end of it, NetworkManager should be showing the device in the menu.  When you see this:

Exported modem
/sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 as
/org/freedesktop/ModemManager/Modems/1

that means that ModemManager has completed initializing detecting the modem.  Were you able to connect the device to the cell network after this point?
Comment 8 Bob Kozdemba 2010-05-27 10:26:39 EDT
Upgraded the firmware and it is now working. I had to create a new connection with NM in order to see the spinning green balls. Is there some way to confirm that I have a 3G connection?

Below is the modem-manager debug output after the upgrade.

Thanks very much for the help!

[root@fugue ~]# modem-manager --debug
** Message: ModemManager (version 0.4.0-0.1.el6) starting...
** Message: Loaded plugin ZTE
** Message: Loaded plugin Ericsson MBM
** Message: Loaded plugin Huawei
** Message: Loaded plugin Option
** Message: Loaded plugin Longcheer
** Message: Loaded plugin Gobi
** Message: Loaded plugin MotoC
** Message: Loaded plugin SimTech
** Message: Loaded plugin AnyData
** Message: Loaded plugin Option High-Speed
** Message: Loaded plugin Sierra
** Message: Loaded plugin Novatel
** Message: Loaded plugin Nokia
** Message: Loaded plugin Generic
** (modem-manager:13411): DEBUG: (tty/ttyS0): port's parent platform driver is not whitelisted
** (modem-manager:13411): DEBUG: (tty/ttyS1): port's parent platform driver is not whitelisted
** (modem-manager:13411): DEBUG: (tty/ttyS2): port's parent platform driver is not whitelisted
** (modem-manager:13411): DEBUG: (tty/ttyS3): port's parent platform driver is not whitelisted
** (modem-manager:13411): DEBUG: (net/pan0): could not get port's parent device
** (modem-manager:13411): DEBUG: (net/sat0): could not get port's parent device
** (modem-manager:13411): DEBUG: (net/sme0): could not get port's parent device
** Message: (ttyUSB0) opening serial device...
** (modem-manager:13411): DEBUG: <1274969338.389670> (ttyUSB0) device open count is 1 (open)
** (modem-manager:13411): DEBUG: (ttyUSB0): probe requested by plugin 'Sierra'
** Message: (ttyUSB1) opening serial device...
** (modem-manager:13411): DEBUG: <1274969338.398669> (ttyUSB1) device open count is 1 (open)
** (modem-manager:13411): DEBUG: (ttyUSB1): probe requested by plugin 'Sierra'
** Message: (ttyUSB2) opening serial device...
** (modem-manager:13411): DEBUG: <1274969338.403683> (ttyUSB2) device open count is 1 (open)
** (modem-manager:13411): DEBUG: (ttyUSB2): probe requested by plugin 'Sierra'
** (modem-manager:13411): DEBUG: <1274969338.460858> (ttyUSB1): <-- '~\1\20x\0\3\0\1\16\1\0\0\0\-128w\0\0\0\0\1\4\0\0\1\0\-1\-1\-1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\4NETWORK SERVICE CHANGE\0\0\-116\-12(\16`B\-115\16\0\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\14\16\7\-48\4\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0~'
** (modem-manager:13411): DEBUG: <1274969338.490734> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:13411): DEBUG: <1274969339.291871> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969339.293758> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:13411): DEBUG: <1274969340.94886> (ttyUSB2): --> 'AT+GCAP<CR>'
** (modem-manager:13411): DEBUG: <1274969340.896155> (ttyUSB1): <-- '~\0\31F\0\0\3\0\27\1\0\1\0\0;\-97\-107\-128\31\-57\-1281\-32s\-2!\27c\-30\6\-90\-125\15\-112\0\-119~'
** (modem-manager:13411): DEBUG: <1274969340.896269> (ttyUSB2): <-- 'AT+GCAP<CR><CR><LF>+GCAP: +CGSM,+DS,+ES<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969340.896363> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:13411): DEBUG: <1274969341.697498> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969341.697559> (ttyUSB2) device open count is 0 (close)
** Message: (ttyUSB2) closing serial device...
** Message: (ttyUSB2) type primary claimed by /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** Message: (ttyUSB2) opening serial device...
** (modem-manager:13411): DEBUG: <1274969341.711668> (ttyUSB2) device open count is 1 (open)
** Message: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB2
** (modem-manager:13411): DEBUG: Added modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:13411): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:13411): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:13411): DEBUG: <1274969341.711839> (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:13411): DEBUG: <1274969342.512880> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969342.512981> (ttyUSB2): <-- '<CR><LF>+PACSP0<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969342.513077> (ttyUSB2): --> 'AT+CPIN?<CR>'
** (modem-manager:13411): DEBUG: <1274969342.523326> (ttyUSB2): <-- 'AT+CPIN?'
** (modem-manager:13411): DEBUG: <1274969342.523414> (ttyUSB0): --> 'ATI<CR>'
** (modem-manager:13411): DEBUG: <1274969342.923978> (ttyUSB0): <-- 'Sierra Wireless, Inc.<LF><CR>MC8781<LF><CR>APP1<LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969342.924073> (ttyUSB2): <-- '<CR><CR><LF>+CPIN: READY<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969342.924226> (ttyUSB2) device open count is 0 (close)
** Message: (ttyUSB2) closing serial device...
** (modem-manager:13411): DEBUG: (tty/ttyUSB0): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** Message: (ttyUSB0) type secondary claimed by /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:13411): DEBUG: <1274969342.934392> (ttyUSB0) device open count is 0 (close)
** Message: (ttyUSB0) closing serial device...
** Message: (Sierra): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 claimed port ttyUSB0
** (modem-manager:13411): DEBUG: (tty/ttyUSB1): outstanding support task prevents export of /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2
** (modem-manager:13411): DEBUG: <1274969343.200302> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:13411): DEBUG: <1274969344.1674> (ttyUSB1): <-- '~\1\20x\0\3\0\1\16\7\8\0A\0T\0&\0T\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\4NETWORK SERVICE CHANGE\0\0\-116\-12(\16`B\-115\16\0\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\14\16\7\-48\4\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0~'
** (modem-manager:13411): DEBUG: <1274969347.199324> (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:13411): DEBUG: <1274969351.198924> (ttyUSB1) device open count is 0 (close)
** Message: (ttyUSB1) closing serial device...
** Message: (ttyUSB1) opening serial device...
** (modem-manager:13411): DEBUG: <1274969351.213715> (ttyUSB1) device open count is 1 (open)
** (modem-manager:13411): DEBUG: <1274969351.213823> (ttyUSB1): --> 00 78 f0 7e
** (modem-manager:13411): DEBUG: <1274969354.203498> (ttyUSB1): --> 00 78 f0 7e
** (modem-manager:13411): DEBUG: <1274969357.202653> (ttyUSB1) device open count is 0 (close)
** Message: (ttyUSB1) closing serial device...
** (modem-manager:13411): DEBUG: (tty/ttyUSB1): ignoring port unsupported by physical modem's plugin
** (modem-manager:13411): DEBUG: Exported modem /sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2 as /org/freedesktop/ModemManager/Modems/0
** (modem-manager:13411): DEBUG: (/org/freedesktop/ModemManager/Modems/0): data port is ttyUSB2
** Message: (ttyUSB2) opening serial device...
** (modem-manager:13411): DEBUG: <1274969413.500766> (ttyUSB2) device open count is 1 (open)
** (modem-manager:13411): DEBUG: <1274969413.500799> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
** (modem-manager:13411): DEBUG: <1274969413.601863> (ttyUSB2): --> 'ATZ E0 V1<CR>'
** (modem-manager:13411): DEBUG: <1274969413.613712> (ttyUSB2): <-- 'ATZ E0 V1'
** (modem-manager:13411): DEBUG: <1274969413.613860> (ttyUSB2): <-- '<CR>'
** (modem-manager:13411): DEBUG: <1274969413.653608> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969413.653660> (ttyUSB2): --> 'ATE0<CR>'
** (modem-manager:13411): DEBUG: <1274969413.661704> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969413.661807> (ttyUSB2): --> 'AT+CMEE=1<CR>'
** (modem-manager:13411): DEBUG: <1274969413.672983> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969413.673122> (ttyUSB2): --> 'ATX4 &C1<CR>'
** (modem-manager:13411): DEBUG: <1274969413.682865> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969413.682902> (ttyUSB2): --> 'AT+CFUN=1<CR>'
** (modem-manager:13411): DEBUG: <1274969413.695742> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** Message: (ttyUSB0) opening serial device...
** (modem-manager:13411): DEBUG: <1274969424.208829> (ttyUSB0) device open count is 1 (open)
** (modem-manager:13411): DEBUG: <1274969424.209018> (ttyUSB2): --> 'AT+IFC=1,1<CR>'
** (modem-manager:13411): DEBUG: <1274969424.223053> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.223172> (ttyUSB2): --> 'AT+GMI<CR>'
** (modem-manager:13411): DEBUG: <1274969424.231147> (ttyUSB2): <-- '<CR><LF>Sierra Wireless, Inc.<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.231271> (ttyUSB2): --> 'AT+GMM<CR>'
** (modem-manager:13411): DEBUG: <1274969424.240745> (ttyUSB2): <-- '<CR><LF>MC8781<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.240912> (ttyUSB2): --> 'AT+GMR<CR>'
** (modem-manager:13411): DEBUG: <1274969424.249764> (ttyUSB2): <-- '<CR><LF>F1_2_3_15AP C:/WS/FW/F1_2_3_15AP/MSM7200R3/SRC/AMSS 2008/07/09 13:02:11<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.249893> (ttyUSB2): --> 'AT+CGMI<CR>'
** (modem-manager:13411): DEBUG: <1274969424.259749> (ttyUSB2): <-- '<CR><LF>Sierra Wireless, Inc.<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.259832> (ttyUSB2): --> 'AT+CGMM<CR>'
** (modem-manager:13411): DEBUG: <1274969424.272675> (ttyUSB2): <-- '<CR><LF>MC8781<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.272757> (ttyUSB2): --> 'AT+CGMR<CR>'
** (modem-manager:13411): DEBUG: <1274969424.283611> (ttyUSB2): <-- '<CR><LF>F1_2_3_15AP C:/WS/FW/F1_2_3_15AP/MSM7200R3/SRC/AMSS 2008/07/09 13:02:11<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.283671> (ttyUSB2): --> 'AT!SELRAT?<CR>'
** (modem-manager:13411): DEBUG: <1274969424.298739> (ttyUSB2): <-- '<CR><LF>!SELRAT: 03, UMTS 3G Preferred<CR><LF><CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.298988> (ttyUSB2): --> 'AT+CSCS=?<CR>'
** (modem-manager:13411): DEBUG: <1274969424.310077> (ttyUSB2): <-- '<CR><LF>+CSCS: ("IRA","GSM","UCS2","PCCP437")<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.310214> (ttyUSB2): --> 'AT+CSCS="UCS2"<CR>'
** (modem-manager:13411): DEBUG: <1274969424.327732> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.327844> (ttyUSB2): --> 'AT+CSCS?<CR>'
** (modem-manager:13411): DEBUG: <1274969424.337850> (ttyUSB2): <-- '<CR><LF>+CSCS: "UCS2"<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.338019> Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> enabled)
** (modem-manager:13411): DEBUG: <1274969424.338234> (ttyUSB2): --> 'AT+CREG=2<CR>'
** (modem-manager:13411): DEBUG: <1274969424.349819> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.349854> (ttyUSB2): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969424.358735> (ttyUSB2): <-- '<CR><LF>+CSQ: 10,99<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.359016> (ttyUSB2): --> 'AT+CREG?<CR>'
** (modem-manager:13411): DEBUG: <1274969424.369064> (ttyUSB2): <-- '<CR><LF>+CREG: 2,1,7147,060FC3FF<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: Registration state changed: 1
** (modem-manager:13411): DEBUG: <1274969424.369235> Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabled -> registered)
** (modem-manager:13411): DEBUG: <1274969424.369350> (ttyUSB2): --> 'AT+CGREG=2<CR>'
** (modem-manager:13411): DEBUG: <1274969424.382567> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.382656> (ttyUSB2): --> 'AT+COPS=3,2;+COPS?<CR>'
** (modem-manager:13411): DEBUG: <1274969424.405597> (ttyUSB2): <-- '<CR><LF>+COPS: 0,2,"310410",2<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.405676> (ttyUSB2): --> 'AT+COPS=3,0;+COPS?<CR>'
** (modem-manager:13411): DEBUG: <1274969424.428598> (ttyUSB2): <-- '<CR><LF>+COPS: 0,0,"AT&T@",2<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.428714> (ttyUSB2): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969424.437680> (ttyUSB2): <-- '<CR><LF>+CSQ: 10,99<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.437815> (ttyUSB2): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969424.455936> (ttyUSB2): <-- '<CR><LF>*CNTI: 0,HSDPA/HSUPA<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969424.456200> (ttyUSB2): --> 'AT+CGREG?<CR>'
** (modem-manager:13411): DEBUG: <1274969424.468705> (ttyUSB2): <-- '<CR><LF>+CGREG: 2,1,7147,060FC3FF<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969454.229689> (ttyUSB2): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969454.239696> (ttyUSB2): <-- '<CR><LF>+CSQ: 10,99<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969454.239871> (ttyUSB2): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969454.259770> (ttyUSB2): <-- '<CR><LF>*CNTI: 0,HSDPA/HSUPA<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969484.227749> (ttyUSB2): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969484.237696> (ttyUSB2): <-- '<CR><LF>+CSQ: 10,99<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969484.237864> (ttyUSB2): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969484.256744> (ttyUSB2): <-- '<CR><LF>*CNTI: 0,HSDPA/HSUPA<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969491.494765> (ttyUSB2): --> 'AT!SELRAT=0<CR>'
** (modem-manager:13411): DEBUG: <1274969491.530724> (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969491.530927> (ttyUSB2): --> 'AT+CREG?<CR>'
** (modem-manager:13411): DEBUG: <1274969491.541604> (ttyUSB2): <-- '<CR><LF>+CREG: 2,1,7147,060FC3FF<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969491.541701> (ttyUSB2): --> 'AT+CGDCONT?<CR>'
** (modem-manager:13411): DEBUG: <1274969491.556752> (ttyUSB2): <-- '<CR><LF>+CGDCONT: 1,"IP","ISP.CINGULAR","",0,0<CR><LF>+CGDCONT: 16,"IP","isp.cingular","",0,0<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969491.557008> Modem /org/freedesktop/ModemManager/Modems/0: state changed (registered -> connecting)
** (modem-manager:13411): DEBUG: <1274969491.557104> (ttyUSB2): --> 'ATD*99***1#<CR>'
** (modem-manager:13411): DEBUG: <1274969491.574737> (ttyUSB2): <-- '<CR><LF>CONNECT<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969491.574853> (ttyUSB2): port now connected
** (modem-manager:13411): DEBUG: <1274969491.574927> Modem /org/freedesktop/ModemManager/Modems/0: state changed (connecting -> connected)
** (modem-manager:13411): DEBUG: (net/ppp0): could not get port's parent device
** (modem-manager:13411): DEBUG: <1274969514.200367> (ttyUSB0): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969514.209701> (ttyUSB0): <-- '+CSQ: 10,99<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969514.209844> (ttyUSB0): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969514.221089> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969544.226709> (ttyUSB0): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969544.235684> (ttyUSB0): <-- '+CSQ: 10,99'
** (modem-manager:13411): DEBUG: <1274969544.236673> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969544.236804> (ttyUSB0): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969544.248150> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969574.206339> (ttyUSB0): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969574.214307> (ttyUSB0): <-- '+CSQ: 10,99'
** (modem-manager:13411): DEBUG: <1274969574.215600> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969574.215721> (ttyUSB0): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969574.228731> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969604.230046> (ttyUSB0): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969604.238072> (ttyUSB0): <-- '+CSQ: 10,99'
** (modem-manager:13411): DEBUG: <1274969604.239639> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969604.239765> (ttyUSB0): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969604.253223> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969634.212112> (ttyUSB0): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969634.220111> (ttyUSB0): <-- '+CSQ: 10,99'
** (modem-manager:13411): DEBUG: <1274969634.221601> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969634.221727> (ttyUSB0): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969634.233678> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969664.209771> (ttyUSB0): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969664.218675> (ttyUSB0): <-- '+CSQ: 10,99'
** (modem-manager:13411): DEBUG: <1274969664.219680> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969664.219803> (ttyUSB0): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969664.232680> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969694.229995> (ttyUSB0): --> 'AT+CSQ<CR>'
** (modem-manager:13411): DEBUG: <1274969694.238676> (ttyUSB0): <-- '+CSQ: 10,99'
** (modem-manager:13411): DEBUG: <1274969694.239634> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:13411): DEBUG: <1274969694.239783> (ttyUSB0): --> 'AT*CNTI=0<CR>'
** (modem-manager:13411): DEBUG: <1274969694.251671> (ttyUSB0): <-- '<CR><LF>OK<CR><LF>'


[bkozdemb@fugue ~]$
Comment 10 Dan Williams 2010-06-29 13:14:59 EDT
That looks like it's working correctly.  If you run 'nm-tool' from a terminal, it'll tell you the IP address of the device.  You can disconnect all other connection methods and try ping if you need more confirmation, but it looks like we're doing OK here.

Note You need to log in before you can comment on or make changes to this bug.