Bug 596567 - [abrt] crash in liferea-1:1.6.2-2.fc12: raise: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
[abrt] crash in liferea-1:1.6.2-2.fc12: raise: Process /usr/bin/liferea was k...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
abrt_hash:1c8007df859d3ac19bb137135b9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 20:54 EDT by Pete Zaitcev
Modified: 2010-06-25 17:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 17:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (27.97 KB, text/plain)
2010-05-26 20:54 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2010-05-26 20:54:17 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: liferea
component: liferea
crash_function: raise
executable: /usr/bin/liferea
global_uuid: 1c8007df859d3ac19bb137135b97f47ff5494d13
kernel: 2.6.32.12-115.fc12.x86_64
package: liferea-1:1.6.2-2.fc12
rating: 4
reason: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)
How to reproduce: unknown

comment
-----
It crashed 3 times in 2 days. Suspected a bad feed that I'm hit intermittently,
possibly related to Java. But even so, 1. why crash, 2. no way to work around.
Comment 1 Pete Zaitcev 2010-05-26 20:54:19 EDT
Created attachment 417075 [details]
File: backtrace
Comment 2 Pete Zaitcev 2010-05-26 21:00:03 EDT
I looked at other 2 traces, the seem pretty much the same: java plugin,
glibc abort.

BTW, "/etc/alternatives/../../bin/java" does not exist, never existed
(it's in /usr at the least).
Comment 3 Juan J. Martínez 2010-05-29 15:22:32 EDT
Same here, and it's Java related:

** (liferea:10188): DEBUG: NP_Initialize
** (liferea:10188): DEBUG: NP_Initialize succeeded
/builddir/build/BUILD/icedtea6-1.8/plugin/icedteanp/IcedTeaNPPlugin.cc:1508: thread 0x857c038: Error: Failed to spawn applet viewer: Failed to execute child process "/usr/lib/mozilla/plugins/../../bin/java" (No such file or directory)
*** glibc detected *** liferea: free(): invalid pointer: 0x08a38318 ***
....
Comment 4 Juan J. Martínez 2010-05-29 15:24:15 EDT
BTW, that path doesn't exist:

ls /usr/lib/mozilla/plugins/../../bin
ls: cannot access /usr/lib/mozilla/plugins/../../bin: No such file or directory

Not said before, but Fedora 12 here.
Comment 5 Juan J. Martínez 2010-05-29 15:26:38 EDT
Workaround here: https://bugzilla.redhat.com/show_bug.cgi?id=592563#c3

Just disable the browser plugins. You'll get the error, but liferea won't crash.
Comment 6 Pete Zaitcev 2010-06-03 14:08:52 EDT
The "Enable Browser Plugins" checkbox is not marked in my Liferea,
so either the root cause is something else, or we have another bug
of Liferea not obeying the configuration.
Comment 7 Adrian Bunk 2010-06-10 16:15:43 EDT
The other bug is likely https://bugs.webkit.org/show_bug.cgi?id=39687
Comment 8 Adrian Bunk 2010-06-10 16:32:10 EDT
Note that the "Component: liferea" is misleading, since like #595466 and #595002 and many more duplicate bug reports this is very likely a bug in WebKitGTK+ and/or the Java plugin.
Comment 9 Juan J. Martínez 2010-06-12 18:28:38 EDT
Just noticed that after webkitgtk-1.2.0-1.fc12.i686 upgrade, liferea seems to work fine again.
Comment 10 Pete Zaitcev 2010-06-25 17:45:39 EDT
I opened a new bug 608180 for F13 where the traceback is a bit different.
Cannot reproduce F12 bugs anymore, closing.

Note You need to log in before you can comment on or make changes to this bug.