Bug 596631 - [abrt] crash in gnome-packagekit-2.30.1-1.fc13: Process /usr/bin/gpk-dbus-service was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in gnome-packagekit-2.30.1-1.fc13: Process /usr/bin/gpk-dbus-ser...
Status: CLOSED DUPLICATE of bug 583250
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit   
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a1bf66e99ebbdc3474653bcbd6f...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 07:55 UTC by Alexey Kazakov
Modified: 2010-11-09 13:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-09 13:49:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.49 KB, text/plain)
2010-05-27 07:55 UTC, Alexey Kazakov
no flags Details

Description Alexey Kazakov 2010-05-27 07:55:40 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/gpk-dbus-service
component: gnome-packagekit
crash_function: gpk_dbus_task_install_files_cb
executable: /usr/bin/gpk-dbus-service
global_uuid: a1bf66e99ebbdc3474653bcbd6f3749c770295ea
kernel: 2.6.33.4-95.fc13.x86_64
package: gnome-packagekit-2.30.1-1.fc13
rating: 4
reason: Process /usr/bin/gpk-dbus-service was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
I was installing http://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm with gpk-install-local-file. All dependencies were installed, and when installation process was about to end -- gpk-install-local-file reported something like "unknown error" and this crashreport were generated.

Launching PackageKit after that reported that there are unfinished transactions that need to be cleaned up with 'yum-complete-transaction'. Yum output for the last command was:
> There are 1 outstanding transactions to complete. Finishing the most recent one
> The remaining transaction had 1 elements left to run
> Nothing in the unfinished transaction to cleanup.
> Cleaning up completed transaction file

Second try to install the same rpm file went flawlessly, and google chrome is installed and working now.

How to reproduce
-----
1. Download http://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm
2. Try to install it with gpk-install-local-file
3. There were an error in the very end of the process.

I'm not sure if the issue was with that very rpm file or it could be any.
Second try to do the same thing went flawlessly without any error.

Comment 1 Alexey Kazakov 2010-05-27 07:55:43 UTC
Created attachment 417143 [details]
File: backtrace

Comment 2 Karel Klíč 2010-11-09 13:49:33 UTC

*** This bug has been marked as a duplicate of bug 583250 ***

Comment 3 Karel Klíč 2010-11-09 13:49:33 UTC
This bug appears to have been filled using a buggy version of ABRT, because
it contains a backtrace which is a duplicate of backtrace from bug #583250.

Sorry for the inconvenience.


Note You need to log in before you can comment on or make changes to this bug.