Bug 596642 - Confusing Error Messages Displayed When Switching Displays
Confusing Error Messages Displayed When Switching Displays
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-settings-daemon (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Rui Matos
Desktop QE
Contest
:
Depends On:
Blocks: 662543
  Show dependency treegraph
 
Reported: 2010-05-27 04:40 EDT by Marko Myllynen
Modified: 2017-12-06 07:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 610482 None None None Never

  None (edit)
Description Marko Myllynen 2010-05-27 04:40:11 EDT
Description of problem:
This only small usability issue, please feel free to handle this as you like.

When connecting an external display to a laptop and hitting the display switch key everything works as expected but GNOME display one (or two, varies) confusing notification windows which say something incomprehensible for a random user:

"
Could not switch the monitor configuration

could not set configuration for CRTC 143
"

When hitting the display switch key again, this message is not displayed. It seems be displayed only for the first time after an external display is connected or disconnected. All the time all displays work all ok.

I'll attach dmesg/X/sys logs from one system showing this but my untrained eye couldn't see anything there and this also happens on some other models (and other display drivers).

Version-Release number of selected component (if applicable):
RHEL 6.0 Snapshot 4
Comment 5 RHEL Product and Program Management 2010-06-04 09:43:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 9 Ray Strode [halfline] 2010-07-20 13:51:39 EDT
proposing for 6.1
Comment 11 RHEL Product and Program Management 2011-01-07 10:34:38 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 12 Jan Kurik 2017-12-06 07:59:56 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.