Bug 596690 - missing package btrfs-progs for i686
missing package btrfs-progs for i686
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: btrfs-progs (Show other bugs)
6.0
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Josef Bacik
Michal Nowak
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 06:19 EDT by Lubos Kocman
Modified: 2013-03-07 21:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
BTRFS is going to be Tech Preview only for x86_64, you will not be able to use it on any other architecture.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 10:25:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Kocman 2010-05-27 06:19:31 EDT
Description of problem:

I'm unable to install btrfs-progs on i686 as package is not available.

Actual results:

no btrfs-progs package for i686

Expected results:

btrfs-progs package for i686


Additional info:

mkfs.btrfs is available on installation media (i686/dvd) but not on the installed system.
Comment 2 Lubos Kocman 2010-05-27 06:24:08 EDT
> 
> mkfs.btrfs is available on installation media (i686/dvd) but not on the
> installed system.

This mean that I can use mkfs.btrfs utility from the command line of the booted dvd. 

Not that package is available between packages that will be installed from installation dvd.
Comment 3 RHEL Product and Program Management 2010-05-27 06:47:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Josef Bacik 2010-05-27 09:39:42 EDT
Btrfs is only going to be available for x86_64, this is not a bug.
Comment 7 Josef Bacik 2010-05-27 10:04:53 EDT
You cannot install onto btrfs with any flavors of RHEL, the option is disabled in anaconda.
Comment 8 Josef Bacik 2010-05-27 14:38:40 EDT
Ok looks like I need to add ExclusiveArch to btrfs-progs to make it only build on x86_64.  As soon as I get confirmation on that I will use this bz for that.
Comment 10 Josef Bacik 2010-06-07 09:47:33 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
BTRFS is going to be Tech Preview only for x86_64, you will not be able to use it on any other architecture.
Comment 16 releng-rhel@redhat.com 2010-11-11 10:25:47 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.