Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 596694 - PMQoS dbus (/proc) communication problem
PMQoS dbus (/proc) communication problem
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
: Regression, RHELNAK
Depends On: 519967
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 06:24 EDT by Jan Ščotka
Modified: 2010-08-05 01:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 01:35:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Ščotka 2010-05-27 06:24:22 EDT
There was a problem with kernel interface for PMQoS some times ago.
How is state now? It is okay now.
There should be communication over Dbus between
power management - dbus - kernel - proc dirs
Comment 2 Richard Hughes 2010-06-01 08:37:11 EDT
The /dev/cpu_dma_latency and /dev/network_latency device files are missing in el6 and fedora kernels for some reason.

The supported devices are the e1000e, ipw2100, and igbvf. I have the former installed, so I should be getting the pmqos interface files. I'm doing some more debugging now, and am waiting for test kernels to compile.
Comment 3 Andy Gospodarek 2010-06-04 11:28:57 EDT
Seems to be working for me:

$ uname -a 
Linux eeepc 2.6.32.9-70.fc12.i686 #1 SMP Wed Mar 3 05:14:32 UTC 2010 i686 i686 i386 GNU/Linux
$ ls /dev | grep latency
cpu_dma_latency
network_latency
Comment 4 Richard Hughes 2010-06-21 09:46:03 EDT
I'm half way through a test document. I should be finished in the next few days.
Comment 6 RHEL Product and Program Management 2010-07-28 12:37:43 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Note You need to log in before you can comment on or make changes to this bug.