Bug 5967 - foul hosts configuration
foul hosts configuration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-14 17:38 EDT by richard-kelley
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-07 12:40:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description richard-kelley 1999-10-14 17:38:31 EDT
On a system with dual nics, the /etc/hosts file created
during installation and as changed by linuxconf is
disfunctional.

127.0.0.1 localhost.localdomain localhost p6012.cfaa.ufl.edu
128.227.160.14  s05.cfaa.ufl.edu
10.5.6.12       p6012.cfaa.ufl.edu

This causes the system to attempt to serve web pages from
localhost.localdomain which aside from the initial page
produces errors for all other content.

A functional version of /etc/hosts is
127.0.0.1      localhost.localdomain localhost
128.227.160.14 s05.cfaa.ufl.edu      s05
10.5.6.12      p6012.cfaa.ufl.edu    p6012

Unfortunately, the only single nic system I have I did an
upgrade on rather than a fresh install, so I can not address
the issue other than on a dual nic system.
Comment 1 jrjohns 1999-11-02 13:52:59 EST
I can concur that this is a problem on single-NIC systems.
The following is the actual output of a single NIC system (this is all
on one line in the file):

127.0.0.1               localhost.localdomain localhost
flounder.r2tech.com

As you can see, the above is not correct at all.  It should
have been something like:

127.0.0.1               localhost.localdomain localhost
10.0.1.4                flounder.r2tech.com

Even more preferrable would be:
127.0.0.1               localhost.localdomain localhost
10.0.1.4                flounder.r2tech.com flounder
Comment 2 Michael K. Johnson 1999-11-19 10:24:59 EST
Added Jacques to CC line
Comment 3 Nalin Dahyabhai 2000-01-07 12:40:59 EST
*** This bug has been marked as a duplicate of 5964 ***

Note You need to log in before you can comment on or make changes to this bug.