This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 596725 - Feature Request: Auto Discovery of Response Time Log for JBoss
Feature Request: Auto Discovery of Response Time Log for JBoss
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
3.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 07:48 EDT by Jochen Riedlinger
Modified: 2014-05-29 14:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-29 14:13:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jochen Riedlinger 2010-05-27 07:48:37 EDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2) Gecko/20100115 Firefox/3.6

After our embedded webapps are discovered it would be nice if (on the inventory/connection tab) the response time log file path would be set automatically from autodiscovery.
Perhaps this could be done in conjunction with naming conventions used in the RhqRtFilter.

We use Maven to create our EARs and embedded WARs and have the version number in their filenames. When we update to new versions of our applications the files/applications with the new names are found (and we uninventory the old ones)
Since we have about 15 of these embedded WAR files on each of our cluster nodes ther's a lot of work configuring the "Response Time Log File"-path for each WAR.

(In JOPR 2.3.? this already worked. It would be nice if you can restore that feature.)

Reproducible: Always

Steps to Reproduce:
1. Deploy WAR or EAR with embedded WAR on JBoss EAP 5.0.0
2. Navigate to that WAR -> Inventory -> Connection
3. The entry for "Response Time Log File" is empty


Expected Results:  
The path to the rt-logfile should be there from autodiscovery
Comment 1 Jay Shaughnessy 2014-05-29 14:13:15 EDT
Please re-open if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.