Bug 596734 - gawk testsuite fails
Summary: gawk testsuite fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gawk   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Zeleny
QA Contact: David Kutálek
URL:
Whiteboard:
Keywords:
Depends On: 522235
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 12:10 UTC by David Kutálek
Modified: 2010-11-10 20:24 UTC (History)
2 users (show)

Fixed In Version: gawk-3.1.7-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 522235
Environment:
Last Closed: 2010-11-10 20:24:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Kutálek 2010-05-27 12:10:46 UTC
+++ This bug was initially created as a clone of Bug #522235 +++

The following tests fail in gawk test suite:

double1 and double2 fail on 64bit archs (ppc64, s390x, and x86_64)
intformat fails on x86_64

This indicates that the results of certain numeric computations can differ across platforms, in certain rare cases.

This is not a serious obstacle in real-life, though.

Moreover, "make check" does not set an exit code, even though some tests fail; this is more serious as it might cause serious breakage to be overseen.

Comment 1 RHEL Product and Program Management 2010-05-27 15:35:55 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Jan Zeleny 2010-05-28 07:57:34 UTC
Failing tests pointed to an error in gawk when handling long integers. It is fixed. As for return code of test suite - I believe it is a feature, the test suite doesn't seem to be meant as automated tool.

Comment 6 David Kutálek 2010-06-03 08:14:01 UTC
There is still some problems, only on s390x, in libsisegv:

...
make  check-TESTS
make[3]: Entering directory `/root/upstream-testsuite/manualne/gawk-3.1.7/libsigsegv/tests'
SKIP: sigsegv1
SKIP: sigsegv2
SKIP: sigsegv3
Starting recursion pass 1.
/bin/sh: line 5:   947 Segmentation fault      (core dumped) ${dir}$tst
FAIL: stackoverflow1
SKIP: stackoverflow2
======================
1 of 1 test failed
(4 tests were not run)
======================
make[3]: *** [check-TESTS] Error 1
make[3]: Leaving directory `/root/upstream-testsuite/manualne/gawk-3.1.7/libsigsegv/tests'
make[2]: *** [check-am] Error 2
make[2]: Leaving directory `/root/upstream-testsuite/manualne/gawk-3.1.7/libsigsegv/tests'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/root/upstream-testsuite/manualne/gawk-3.1.7/libsigsegv'
make: *** [check-recursive] Error 1

Jan, please can you inspect?

Comment 7 Jan Zeleny 2010-06-03 09:03:13 UTC
Gawk is compiled without libsigsegv support. Could it be the reason of that error? I believe it could.

Comment 8 Jan Zeleny 2010-06-04 09:29:22 UTC
I tried to investigate it further, but I have only limited knowledge of autotools, so I wasn't able to find anything. For all I know, libsigsegv isn't compiled in gawk and thus all its tests should be excluded from test suite.

Comment 9 David Kutálek 2010-06-14 10:13:09 UTC
Ok, the problem was in fact caused by my testing script.
Now it is running the testsuite without libsigsegv and also on s390 is now passing.

Comment 11 releng-rhel@redhat.com 2010-11-10 20:24:28 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.