Bug 596737 - install dies with KeyError: 'cciss/c' on systems with smart array
install dies with KeyError: 'cciss/c' on systems with smart array
Status: CLOSED DUPLICATE of bug 559507
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity urgent
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 08:16 EDT by Doug Chapman
Modified: 2010-05-27 09:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 09:54:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2010-05-27 08:16:06 EDT
Description of problem:
When installing RHEL6 Snapshot 5 on hp-bl480c-01.rhts.eng.bos.redhat.com (and I assume anything else with a smart array controller).  The install dies with the error shown below.  This is a regression from Snapshot 4.


Running anaconda 13.21.45, the Red Hat Enterprise Linux system installer - please wait.
Finding storage devices
anaconda 13.21.45 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/mpath.py", line 102, in identifyMultipaths
    singlepath_disks.append(devmap[disks[0]])
  File "/usr/lib/anaconda/storage/devicetree.py", line 1999, in populate
    (singles, mpaths, partitions) = devicelibs.mpath.identifyMultipaths(devices)
  File "/usr/lib/anaconda/storage/__init__.py", line 379, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/bin/anaconda", line 1089, in <module>
    storage.storageInitialize(anaconda)
KeyError: 'cciss/c'

install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 David Cantrell 2010-05-27 09:54:56 EDT

*** This bug has been marked as a duplicate of bug 559507 ***

Note You need to log in before you can comment on or make changes to this bug.