Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 596779 - Fedora 13 kpackagekit fails - "A problem that we were not expecting has occurred..."
Fedora 13 kpackagekit fails - "A problem that we were not expecting has occur...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 09:56 EDT by Robert Gadsdon
Modified: 2010-06-10 15:15 EDT (History)
8 users (show)

See Also:
Fixed In Version: PackageKit-0.6.5-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 15:15:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Gadsdon 2010-05-27 09:56:19 EDT
Recent upgrade from F12 to F13 - X86_64 on quad-core Intel Core2.

kpackagekit worked correctly under F12, but with F13 gives:
   "A problem that we were not expecting has occurred.
    Please report this bug with the error description."
- and the following description:
-----------------------------------------------------------
Error Type: <class 'socket.error'>
Error Value: [Errno 2] No such file or directory
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3418, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3414, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 264, in __init__
    sock.setsockopt(socket.IPPROTO_TCP, socket.TCP_CONGESTION, "lp")
  File : <string>, line 1, in setsockopt
    None
----------------------------------------------------------

Steps to reproduce:
Run kpackagekit
Click on "Software Updates"
  <error>

Versions: kpackagekit-0.6.0-2.fc13.x86_64
          PackageKit-0.6.4-1.fc13.x86_64
          yum-3.2.27-4.fc13.noarch.
Comment 1 Steven M. Parrish 2010-05-27 10:21:59 EDT
I have them same versions on my system and I am unable to reproduce this error.  Can anyone else?

Steven
Comment 2 Richard Hughes 2010-05-27 11:32:00 EDT
Well, I guess we need a try, except: around that code. I'm intrigued what kind of system you have that generated this -- I can't certainly reproduce. Is there anything odd about your system or is it a stock install?

commit 2e3605d941458f77951dba56e4a493b2a456d9d9
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu May 27 16:28:32 2010 +0100

    yum: catch and ignore the socket exception on oddball systems. Fixes rh#596779

Richard.
Comment 3 Robert Gadsdon 2010-05-27 12:03:06 EDT
Updated from Fedora 12 using yum (after updating fedora-release...rpm), due to problem getting the F13 DVD to load/run (despite verification that it seemed OK, and an F12 DVD _did_ load/run correctly in the same DVD drive...).

Robert.
Comment 4 Robert Gadsdon 2010-05-27 12:14:57 EDT
I have just recompiled kpackagekit from the F13 source RPM, and the problem still occurs.

Robert.
Comment 5 Richard Hughes 2010-05-27 12:26:47 EDT
It's not a kpackagekit problem, it's a PackageKit (the daemon) problem.
Comment 6 Fedora Update System 2010-06-02 07:13:22 EDT
PackageKit-0.6.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/PackageKit-0.6.5-1.fc13
Comment 7 Robert Gadsdon 2010-06-02 09:40:09 EDT
Updated PackageKit (X86_64) to version 0.6.5-1.fc13 RPMs, and kpackagekit now works correctly on my system

Thank you.

Robert Gadsdon
June 2nd, 2010
Comment 8 Fedora Update System 2010-06-03 14:08:37 EDT
PackageKit-0.6.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/PackageKit-0.6.5-1.fc13
Comment 9 Fedora Update System 2010-06-10 15:15:17 EDT
PackageKit-0.6.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.