Bug 596818 - fakeroot -- some libraries are not stripped
Summary: fakeroot -- some libraries are not stripped
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: fakeroot   
(Show other bugs)
Version: 5.6
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On: 596735
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 15:05 UTC by Richard W.M. Jones
Modified: 2013-10-30 18:24 UTC (History)
4 users (show)

Fixed In Version: fakeroot-1.12.4-1.el5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 596735
Environment:
Last Closed: 2013-10-30 18:24:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard W.M. Jones 2010-05-27 15:05:18 UTC
+++ This bug was initially created as a clone of Bug #596735 +++

Description of problem:

Two libraries in the fakeroot package are not stripped.  These
are:

$ file /usr/lib64/libfakeroot/libfakeroot-tcp.so
/usr/lib64/libfakeroot/libfakeroot-tcp.so: ELF 64-bit LSB shared object, x86-64, version 1 (GNU/Linux), dynamically linked, not stripped
$ file /usr/lib64/libfakeroot/libfakeroot-sysv.so 
/usr/lib64/libfakeroot/libfakeroot-sysv.so: ELF 64-bit LSB shared object, x86-64, version 1 (GNU/Linux), dynamically linked, not stripped

Version-Release number of selected component (if applicable):

fakeroot-1.12.4-1.fc13.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Run 'file' command on the two files above.
2.
3.
  
Actual results:

Not stripped.

Expected results:

Should be stripped, assuming this doesn't break things.

Additional info:

--- Additional comment from rjones@redhat.com on 2010-05-27 11:04:11 EDT ---

New build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2213062

--- Additional comment from rjones@redhat.com on 2010-05-27 11:04:32 EDT ---

Emmm RAWHIDE not UPSTREAM.

Comment 1 Richard W.M. Jones 2010-05-27 15:44:13 UTC
Built in brew:
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2477323

Comment 3 RHEL Product and Program Management 2010-08-09 18:08:49 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 Jinxin Zheng 2010-09-17 06:33:44 UTC
This is with fakeroot-1.12.4-1.el5.1:

# file /usr/lib64/libfakeroot/libfakeroot-tcp.so
/usr/lib64/libfakeroot/libfakeroot-tcp.so: ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), not stripped
# file /usr/lib64/libfakeroot/libfakeroot-sysv.so 
/usr/lib64/libfakeroot/libfakeroot-sysv.so: ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), not stripped

And with fakeroot-1.12.4-1.el5.2:

# file /usr/lib64/libfakeroot/libfakeroot-tcp.so
/usr/lib64/libfakeroot/libfakeroot-tcp.so: ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), stripped
# file /usr/lib64/libfakeroot/libfakeroot-sysv.so 
/usr/lib64/libfakeroot/libfakeroot-sysv.so: ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), stripped

So move to VERIFIED.

Comment 6 RHEL Product and Program Management 2011-05-31 13:15:32 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 8 RHEL Product and Program Management 2011-09-23 00:07:23 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 9 Richard W.M. Jones 2011-09-23 07:39:13 UTC
This bug is fixed in the package listed in fixed-in-version.

Comment 10 Richard W.M. Jones 2013-10-30 18:24:46 UTC
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification. Issue is already fixed in RHEL-6/7.


Note You need to log in before you can comment on or make changes to this bug.