Bug 596881 - Unable to install RHEL virtual machines
Unable to install RHEL virtual machines
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: seabios (Show other bugs)
6.0
All Linux
low Severity high
: beta
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
: Regression
: 599257 600142 (view as bug list)
Depends On:
Blocks: 578752
  Show dependency treegraph
 
Reported: 2010-05-27 13:21 EDT by Martin Jenner
Modified: 2013-12-08 19:48 EST (History)
12 users (show)

See Also:
Fixed In Version: seabios-0.5.1-0.10.20100108git669c991.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:50:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jenner 2010-05-27 13:21:36 EDT
Description of problem:

I am unable to install any virtual machines, so far testing RHEL6 and RHEL5.5 32 and 64 bit on system installed with RHEL6 snapshot #6


Version-Release number of selected component (if applicable):

Host installed with snapshot #6 tree RHEL6.0-20100526.2

# rpm -q libvirt kernel seabios qemu-kvm
libvirt-0.8.1-7.el6.x86_64
kernel-2.6.32-30.el6.x86_64
seabios-0.5.1-0.9.20100108git669c991.el6.x86_64
qemu-kvm-0.12.1.2-2.68.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. and example install command
# virt-install --connect qemu:///system --hvm --name vm1 --ram 1024 --vnc --location http://download.lab.bos.redhat.com/redhat/rel-eng/RHEL6.0-20100526.2/6/Server/x86_64/os --disk path=/var/lib/libvirt/images/vm1.img.raw,size=6,device=disk,bus=virtio --os-variant=rhel6 --accelerate --debug --network network=default,model=virtio

 
Actual results:
guest boots vmlunz/initrd and then hangs

Expected results:
vm should boot and start installing guest successfully

Additional info:

I can start an existing vm of an image I copied locally and then defined with xml file

Booting the vm directly from an iso also hits this issue
Comment 1 Eduardo Habkost 2010-05-27 14:51:52 EDT
I just used exactly the same virt-install command-line using qemu-kvm-0.12.1.2-2.68.el6.x86_64, and the guest is being installed normally.

I am upgrading my RHEL6 test system to check if the bug depends on other packages being upgraded to the latest snapshot.
Comment 2 Martin Jenner 2010-05-27 15:38:02 EDT
For RHEL 6 guest installation you see similar to below

Loading vmlinuz
Loading initrd................................................
..............................................................
.................................................ready
Probing EDD (edd=off to disable)...

then guest hangs
Comment 3 Eduardo Habkost 2010-05-27 15:55:20 EDT
downgrading to seabios-0.5.1-0.8.20100108git669c991.el6 solves the issue. seabios seems to have been broken by the fix for bug 578752.
Comment 4 Martin Jenner 2010-05-27 17:06:38 EDT
confirmed prior comment works on my test systems that saw the issue, installed and booted both 32 and 64 bit guest with the downgraded seabios
Comment 5 Gleb Natapov 2010-05-28 02:48:40 EDT
What qemu command line this virt-install command generates?
Comment 7 Gleb Natapov 2010-05-31 05:43:56 EDT
*** Bug 596590 has been marked as a duplicate of this bug. ***
Comment 8 Cao, Chen 2010-06-02 02:51:30 EDT
As Martin provided,

"
# rpm -q libvirt kernel seabios qemu-kvm
libvirt-0.8.1-7.el6.x86_64
kernel-2.6.32-30.el6.x86_64
seabios-0.5.1-0.9.20100108git669c991.el6.x86_64
qemu-kvm-0.12.1.2-2.68.el6.x86_64
"

the bug is introduced in the new version
seabios-0.5.1-0.9.20100108git669c991.el6.x86_64

but the bug status is changed to MODIFIED and fixed in a old version
seabios-0.5.1-0.8.20100108git669c991.el6


change the status to NEW.
Comment 12 Amit Shah 2010-06-03 10:41:55 EDT
*** Bug 599257 has been marked as a duplicate of this bug. ***
Comment 15 Amit Shah 2010-06-04 05:11:23 EDT
*** Bug 600142 has been marked as a duplicate of this bug. ***
Comment 17 Suqin Huang 2010-06-11 02:16:27 EDT
windows BSOD reproduce in seabios-0.5.1-0.11.20100108git669c991.el6.x86_64

qemu-kvm-0.12.1.2-2.71.el6.x86_64
2.6.32-33.el6.x86_64
Comment 18 Gleb Natapov 2010-06-11 06:09:06 EDT
What Windows driver are you using?
Comment 20 Eduardo Habkost 2010-06-11 10:07:46 EDT
This bug does not involve windows BSODs. but a specific problem that made linux guests using virtio hang on boot. Please open a new BZ.
Comment 21 Eduardo Habkost 2010-06-11 10:20:57 EDT
(In reply to comment #20)
> This bug does not involve windows BSODs. but a specific problem that made linux
> guests using virtio hang on boot. Please open a new BZ.    

Reopened bug 596590 instead.
Comment 22 Martin Jenner 2010-06-11 11:55:26 EDT
verified with tree RHEL6.0-20100531.1 guest are installable 

# rpm -q seabios
seabios-0.5.1-0.10.20100108git669c991.el6.x86_64
Comment 23 releng-rhel@redhat.com 2010-07-02 15:50:36 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.