Bug 596919 - installing new kernel overwrites custom crashkernel arg
installing new kernel overwrites custom crashkernel arg
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity high
: rc
: ---
Assigned To: Neil Horman
Chao Ye
: Regression
Depends On:
Blocks: 524819
  Show dependency treegraph
 
Reported: 2010-05-27 14:53 EDT by Doug Chapman
Modified: 2011-01-11 02:43 EST (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.32-42.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:55:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct crshkernel updates (1.33 KB, patch)
2010-06-21 07:35 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2010-05-27 14:53:11 EDT
Description of problem:
When a new kernel is installed any custom crashkernel argument that the user had previously set gets changed to crashkernel=auto.  We have some systems which do not function properly with crashkernel=auto (which is a separate issue that I agree should be fixed) however we still should never overwrite an option that a user explicitly set.

This option is set by the %post script in the kernel's rpm spec.  It is currently hard coded and should be modified to check for a pre-existing crashkernel argument as to not overwrite it.



Version-Release number of selected component (if applicable):
all recent RHEL6 kernels up to and including 2.6.32-30.el6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-06-07 12:05:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Doug Chapman 2010-06-15 16:46:20 EDT
We continue to run into new issues with crashkernel=auto.  The patch for this on bug 580843 does not resolve that issue, it only creates a new problem.

It is highly likely that Red Hat support will need to tell some customers to use a hard coded crashkernel arg on certain systems and it would be very bad form for a new kernel install to change something that a user explicitly set.
Comment 4 Neil Horman 2010-06-18 11:34:49 EDT
This is happening because we were too nervous to make a change in the installer directly. Instead we need to append this parameter from the kernel install script in the spec file.  Since the new-kernel-package utiltiy has no way to specify "add this parameter only if it doesn't yet exist" we always add (and overwrite it).  I'll test out a fix shortly.
Comment 5 Neil Horman 2010-06-18 13:15:40 EDT
 http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2532149

Testpatch cooking here
Comment 6 Neil Horman 2010-06-21 07:35:48 EDT
Created attachment 425600 [details]
patch to correct crshkernel updates

herees the patch I'll be posting internally.
Comment 7 Aristeu Rozanski 2010-07-01 12:24:10 EDT
Patch(es) available on kernel-2.6.32-42.el6
Comment 10 Chao Ye 2010-08-13 04:25:46 EDT
Reproduced with kernel-2.6.32-31.el6:
===============================================================================
[root@hp-xw4200-01 ~]# cat /boot/grub/grub.conf | grep crashkernel ;yum list kernel ;rpm -ivh kernel-2.6.32-31.el6.i686.rpm ;cat /boot/grub/grub.conf | grep crashkernel
	kernel /vmlinuz-2.6.32-30.el6.i686 ro root=/dev/mapper/vg_hpxw420001-lv_root rd_LVM_LV=vg_hpxw420001/lv_root rd_LVM_LV=vg_hpxw420001/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=ttyS0,115200 crashkernel=128M
Loaded plugins: rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Installed Packages
kernel.i686                     2.6.32-30.el6                       installed
Available Packages
kernel.i686                     2.6.32-59.1.el6                     beaker-os
Preparing...                                                            (100%########################################### [100%]
   1:kernel                                                             (  1%########################################### [100%]
	kernel /vmlinuz-2.6.32-31.el6.i686 ro root=/dev/mapper/vg_hpxw420001-lv_root rd_LVM_LV=vg_hpxw420001/lv_root rd_LVM_LV=vg_hpxw420001/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=ttyS0,115200 crashkernel=auto
	kernel /vmlinuz-2.6.32-30.el6.i686 ro root=/dev/mapper/vg_hpxw420001-lv_root rd_LVM_LV=vg_hpxw420001/lv_root rd_LVM_LV=vg_hpxw420001/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=ttyS0,115200 crashkernel=128M

Verified with kernel-2.6.32-63:
================================================================================
[root@hp-xw4200-01 ~]# cat /boot/grub/grub.conf | grep crashkernel ;yum list kernel ;rpm -ivh kernel-2.6.32-63.el6.i686.rpm ;cat /boot/grub/grub.conf | grep crashkernel
	kernel /vmlinuz-2.6.32-30.el6.i686 ro root=/dev/mapper/vg_hpxw420001-lv_root rd_LVM_LV=vg_hpxw420001/lv_root rd_LVM_LV=vg_hpxw420001/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=ttyS0,115200 crashkernel=128M
Loaded plugins: rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Installed Packages
kernel.i686                     2.6.32-30.el6                       installed
Available Packages
kernel.i686                     2.6.32-59.1.el6                     beaker-os
Preparing...                                                            (100%########################################### [100%]
   1:kernel                                                             (  1%########################################### [100%]
	kernel /vmlinuz-2.6.32-63.el6.i686 ro root=/dev/mapper/vg_hpxw420001-lv_root rd_LVM_LV=vg_hpxw420001/lv_root rd_LVM_LV=vg_hpxw420001/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=ttyS0,115200 crashkernel=128M
	kernel /vmlinuz-2.6.32-30.el6.i686 ro root=/dev/mapper/vg_hpxw420001-lv_root rd_LVM_LV=vg_hpxw420001/lv_root rd_LVM_LV=vg_hpxw420001/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=ttyS0,115200 crashkernel=128M
================================================================================
Change status to VERIFIED.
Comment 12 releng-rhel@redhat.com 2010-11-10 15:55:14 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.