Bug 596997 - sense logging of ATA PASS-THROUGH commands fills up the logs and scares users
sense logging of ATA PASS-THROUGH commands fills up the logs and scares users
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jeff Moyer
Red Hat Kernel QE team
:
: 570520 591108 (view as bug list)
Depends On:
Blocks: 788777
  Show dependency treegraph
 
Reported: 2010-05-27 17:40 EDT by Jeff Moyer
Modified: 2012-02-08 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 788777 (view as bug list)
Environment:
Last Closed: 2010-11-15 09:25:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch (1.91 KB, text/x-makefile)
2010-05-27 17:40 EDT, Jeff Moyer
no flags Details

  None (edit)
Description Jeff Moyer 2010-05-27 17:40:13 EDT
Created attachment 417397 [details]
upstream patch

Description of problem:
On our server with lots of SAS disks, we see the following:

Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:6:0: [sdcy] Add. Sense: ATA pass through information available
sd 13:0:3:0: [sdcv] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:3:0: [sdcv] Add. Sense: ATA pass through information available
sd 13:0:2:0: [sdcu] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:2:0: [sdcu] Add. Sense: ATA pass through information available
sd 13:0:4:0: [sdcw] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:4:0: [sdcw] Add. Sense: ATA pass through information available
sd 13:0:10:0: [sddc] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:10:0: [sddc] Add. Sense: ATA pass through information available
sd 13:0:11:0: [sddd] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:11:0: [sddd] Add. Sense: ATA pass through information available
sd 13:0:13:0: [sddf] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:13:0: [sddf] Add. Sense: ATA pass through information available
[current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:0:0: [sdcs] Add. Sense: ATA pass through information available
sd 13:0:15:0: [sddh] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:15:0: [sddh] Add. Sense: ATA pass through information available
sd 13:0:21:0: [sddm] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:21:0: [sddm] Add. Sense: ATA pass through information available
sd 13:0:22:0: [sddn] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:22:0: [sddn] Add. Sense: ATA pass through information available
sd 13:0:1:0: [sdct] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 
sd 13:0:1:0: [sdct] Add. Sense: ATA pass through information available
sd 13:0:7:0: [sdcz] Sense Key : Recovered Error [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
        72 01 00 1d 00 00 00 0e 09 0c 00 00 00 00 00 00 
        00 00 00 00 00 00 

etc., etc.

An upstream commit gets rid of this nonsense:

commit e7efe5932b1d3916c79326a4221693ea90a900e2
Author: Douglas Gilbert <dgilbert@interlog.com>
Date:   Sun Jan 3 13:51:15 2010 -0500

    [SCSI] skip sense logging for some ATA PASS-THROUGH cdbs
    
    Further to the lsml thread titled:
    "does scsi_io_completion need to dump sense data for ata pass through (ck_co
    1) ?"
    
    This is a patch to skip logging when the sense data is
    associated with a SENSE_KEY of "RECOVERED_ERROR" and the
    additional sense code is "ATA PASS-THROUGH INFORMATION
    AVAILABLE". This only occurs with the SAT ATA PASS-THROUGH
    commands when CK_COND=1 (in the cdb). It indicates that
    the sense data contains ATA registers.
    
    Smartmontools uses such commands on ATA disks connected via
    SAT. Periodic checks such as those done by smartd cause
    nuisance entries into logs that are:
        - neither errors nor warnings
        - pointless unless the cdb that caused them are also logged


Version-Release number of selected component (if applicable):
2.6.32-19

How reproducible:
100%

Steps to Reproduce:
1. boot a box with a default install and a bunch of sas disks
Comment 2 RHEL Product and Program Management 2010-05-27 23:35:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Ben Woodard 2010-06-03 13:01:20 EDT
*** Bug 591108 has been marked as a duplicate of this bug. ***
Comment 5 Aristeu Rozanski 2010-06-03 15:58:15 EDT
Patch(es) available on kernel-2.6.32-32.el6
Comment 9 Linda Wang 2010-08-05 01:32:29 EDT
*** Bug 570520 has been marked as a duplicate of this bug. ***
Comment 10 michal novacek 2010-09-23 10:24:27 EDT
The above mentioned changes are pretty simple and not invasive and are contained in kernel-2.6.32-73.el6 in drivers/scsi/scsi_lib.c which compiles correctly.
Comment 12 releng-rhel@redhat.com 2010-11-15 09:25:18 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.